high beam doesn't work !!!!!

Reply

  #1  
Old 01-31-03, 02:27 PM
Member
Thread Starter
Join Date: Dec 2002
Location: Canada
Posts: 23
high beam doesn't work !!!!!

Hey everyone:
I own a 1996 Chevrolet Cavalier. Driving to work this morning, I was unable to use my high beam lights. When I tried to turn them on ( using the signal light arm ), my lights went out completely! Now I only have low beam, but my high beam indicator on the dash remains lit, whether I try the high beam or not. Any suggestions ????


Thanks in Advance........ ssshep
 
Sponsored Links
  #2  
Old 01-31-03, 04:13 PM
Joe_F
Visiting Guest
Posts: n/a
Check both bulbs to be sure they work, but it sounds like a wasted dimmer switch. May require professional service as the steering column has to come apart and that means dealing with the airbag---don't risk it.
 
  #3  
Old 01-31-03, 04:54 PM
Member
Thread Starter
Join Date: Dec 2002
Location: Canada
Posts: 23
Thanks for the quick reply Joe...... unfortunately, I've checked both bulbs and they test OK. Guess I'm off to the garage.

Thanks again.......... ssshep
 
  #4  
Old 02-01-03, 04:39 AM
Member
Join Date: Nov 2001
Location: North Texas
Posts: 2,345
check this out

Check all the connectors on the steering coloum get under the dash and check them one might have came off.This happend to a buddy of mine with a Camaro.He found a connector had backed out pluged it back in and all was good.Hint use a good flashlight and move stuff around.
 
  #5  
Old 02-12-03, 12:10 PM
Member
Thread Starter
Join Date: Dec 2002
Location: Canada
Posts: 23
Just to let you guys know........... it was a wiring issue, took it to a garage, just in case it was the dimmer switch, but was told the wires were corroded underneath the windshield washer container. Thanks again for the suggestions !!!!!!!!!!!!!!

ssshep
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes