ecm 1990 grand prix 3.1

Reply

  #1  
Old 02-02-03, 12:15 PM
lreel
Visiting Guest
Posts: n/a
Question ecm 1990 grand prix 3.1

My check gauges light and service engine light have been coming on. A loacl garage conducted an engine analysis on my vehicle and advised that there are two possibilities.

1. ECM unit - Where is it located on the vehicle? I have been told it is not difficult to replace.....just a little expensive. Please describe what it looks like.

2. Air charge sensor - same question as above.

No wise remarks please,,,,I am just learning.

I did replace a muffler......a thermostat........and I complete basic services on my own without a problem. I have just never dealt with the electronics or emmission system before.

Any help would be very appreciated.
 
Sponsored Links
  #2  
Old 02-02-03, 01:15 PM
Member
Join Date: Dec 2001
Posts: 2,538
while those problems may be causing a check engine light i doubt it has anything to do with the check guages light.
air charge sensor is usually located on air cleaner box small sensor with 2 wire plug in, the ecm i think is under the hood on the right fender well, usually covered by either plastic inner fender or coolant resoirver bottle. usually a black box with about 4 connectors.
 
  #3  
Old 02-02-03, 01:28 PM
lreel
Visiting Guest
Posts: n/a
Wink 1990 grand prix

Thanks for your help....I'll let you know if I am successful.
 
  #4  
Old 02-02-03, 02:55 PM
Joe_F
Visiting Guest
Posts: n/a
Check gauges has to do with the dashboard gauges. Could have a bad oil pressure switch, charging problem, etc. Are the gauges working normally?
 
  #5  
Old 02-03-03, 03:31 PM
sirslinkster
Visiting Guest
Posts: n/a
does it have a dis ignition or a distributor
 
  #6  
Old 02-04-03, 05:56 AM
Joe_F
Visiting Guest
Posts: n/a
Linkster:

All of these models are distributorless from 1988 up.
 
  #7  
Old 02-04-03, 01:39 PM
sirslinkster
Visiting Guest
Posts: n/a
ok i was thinking it would be under the coils but thats the icm.oh well i got confused
 
  #8  
Old 02-04-03, 02:13 PM
Member
Join Date: Sep 2002
Location: Colorado
Posts: 431
Ireel, I doubt that your computer is bad. That's usually the last thing on the list to replace. You can read the error codes yourself or have them read again after you change the sensor. Write the code numbers down and re-post here and someone should be able to help you further.

Try this link for code retrieval.
http://www.batauto.com/GM
 
  #9  
Old 02-04-03, 06:29 PM
Member
Join Date: Dec 2002
Posts: 30
Did this problem happen after the thermostat R&R? If so, the coolant system was not bled. There is a speciel "bleeder screw" on the thermostat housing to do so. Yes this will set the coolant and engine light/gage on. The ECM/PCM is a known bad unit on this vehicle as well as bad clusters. Repeat, don't jump to replace parts, have it diagnosed correctly.
 
  #10  
Old 02-09-03, 07:02 PM
lreel
Visiting Guest
Posts: n/a
Smile

Thanks to everyone so far.

I bled the cooling system and now the low coolant light is off.

Still have check gauges light and the service engine light keeps coming on.

The oil guage goes high..........off the scale when I accelerate.
It also fluctuates up and down when the vehicle idles.

I really appreciate the help.

Am learning a lot.
 
  #11  
Old 02-09-03, 07:50 PM
Member
Join Date: Dec 2001
Posts: 2,538
if the oil guage is the only guage reading inncorrectly then thatis likely causing your check guages light to come on, good chance you may have a bad oil sending unit causing the problem. you should have codes read on your computer and see what comes up and post back here for the check engine light problem.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes