Seville Intermittent Fast Idle and Acceleration

Reply

  #1  
Old 02-03-03, 05:44 PM
GeoCache
Visiting Guest
Posts: n/a
Seville Intermittent Fast Idle and Acceleration

My 1992 Seville STS has several, apparently related intermittent problems.

About once a week, when the car starts, the engine will rev up to around 3500 RPM and stay there for about 15 seconds before gradually slowing down to a normal idle.

Additionally, about once a week, when cruising along at 40 or 45 MPH, the car will accelerate on its own as if the accelerator or cruise control was stuck. It only goes back to a normal idle after applying the brakes and bringing the car to a complete stop. My mechanic replaced the idle speed control motor but the problem still exists.

Finally, twice in the last 3 months, after turning off the car, the accelerator pedal made a tapping noise. When I opened the hood, the plunger on the idle speed control motor was going in and out and making a clicking noise.

Suggestions anyone? Thanks.
 
Sponsored Links
  #2  
Old 02-03-03, 06:22 PM
Member
Join Date: Dec 2001
Posts: 2,538
sounds to me like a throttle position sensor problem, or incorrectly adjusted throttle position sensor, i would suggest taking to dealership where they for sure have the correct equipment and manuals to fix it and adjust the isc and tps to specification correctly, so atleast your first and third problem doesnt occur.
 
  #3  
Old 02-04-03, 06:06 AM
Joe_F
Visiting Guest
Posts: n/a
I agree with BeJay.
 
  #4  
Old 02-04-03, 06:56 AM
GeoCache
Visiting Guest
Posts: n/a
Thanks guys.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes