Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Speedometer problems


blackaley's Avatar
Visiting Guest

Posts: n/a

02-07-03, 01:54 PM   #1  
blackaley
Speedometer problems

I have a 1994 Ford Ranger. It has a 2.3l four cylinder engine, 5-speed manual transmission, and is 4 wheel drive. The speedometer seems to measure a higher speed than what the vehicle is travelling.(Example: measures 35 but going only 25, measures 55 but going only 45.) This applies until the speedometer reads between 60 and 65. The needle then begins to erratically register even higher readings jumping around depending on the rpms of the engine. The cable seems to be in good shape as it is well lubricated and makes no noise. The speed sensor was replaced but that did not help the problem. Any ideas on what is next?

 
Sponsored Links
Joe_F's Avatar
Visiting Guest

Posts: n/a

02-07-03, 02:41 PM   #2  
Joe_F
Do you have the correct/stock size tires?

 
blackaley's Avatar
Visiting Guest

Posts: n/a

02-07-03, 06:31 PM   #3  
blackaley
speedometer problems

I had four new tires recently put on. They are 235/75-15's. The problem existed before I put the new tires on though.

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

02-07-03, 09:28 PM   #4  
Joe_F
What is the stock tire size for this vehicle?

 
blackaley's Avatar
Visiting Guest

Posts: n/a

02-08-03, 07:13 AM   #5  
blackaley
speedometer problems

My mistake on my previous post. The size tires that I put on were 215/75-15's. I looked on the door and the spec's for my truck are the 215/75-15's. I also checked to see if I got an error code for the vehicle speed sensor and got no errors.

 
Stevo2's Avatar
Member

Join Date: Sep 2002
Posts: 431

02-08-03, 01:27 PM   #6  
You might try removing the VSS and cleaning it, sometimes they get metal particles on them and send strange signals. The only things in this circuit are the VSS, wiring, the PCM and the speedometer. Barring the cleaning, maybe replacement and/or check the connectors, speedometer problems or you might need to have the PCM reprogrammed by Ford.


Vehicle Speed Sensor (VSS)

OPERATION

The Vehicle Speed Sensor (VSS) is a magnetic pick-up that sends a signal to the Powertrain Control Module (PCM). The sensor measures the rotation of the transmission and the PCM determines the corresponding vehicle speed.



TESTING


Turn the ignition switch to the OFF position.
Disengage the wiring harness connector from the VSS.
Using a Digital Volt-Ohmmeter (DVOM), measure the resistance (DVOM ohmmeter function) between the sensor terminals. If the resistance is 190-250 ohms, the sensor is okay.


REMOVAL & INSTALLATION


The VSS is located half-way down the right-hand side of the transmission assembly.

Apply parking brake, block the rear wheels, then raise and safely support the front of the vehicle on jackstands.
From under the right-hand side of the vehicle, disengage the wiring harness connector from the VSS.
Loosen the VSS hold-down bolt, then pull the VSS out of the transmission housing.
To install:

If a new sensor is being installed, transfer the driven gear retainer and gear to the new sensor.
Ensure that the O-ring is properly seated in the VSS housing.
For ease of assembly, engage the wiring harness connector to the VSS, then insert the VSS into the transmission assembly.
Install and tighten the VSS hold-down bolt to 62-88 inch lbs. (7-10 Nm).
Lower the vehicle and remove the wheel blocks.

 
fordtech's Avatar
Member

Join Date: Jun 2001
Posts: 247

02-09-03, 08:55 AM   #7  
I would guess a faulty speedo head,especially if the needle "jumps" as you've stated.Also make sure the speedo gear that attaches to the speed sensor is not hour glassed shaped.Most sensors don't come with a new gear and i've seen a few gears wear into an hour glass shape and also cause this problem.Because the old gear is transfered to the new speedo sensor the mechanic goes looking for another cause not knowing he had just had the cause in his hand!!!

 
Search this Thread