Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

jumping engine


tpprr's Avatar
Visiting Guest

Posts: n/a

02-19-03, 10:32 PM   #1  
tpprr
jumping engine

i have a 95 chevy s10 4x4 with standard transmission. when i accelerate in each gear i feel the front of my truck "jumping or rocking". what the heck could this be? bad engine mounts maybe? 4.3 engine needs a tune-up possibly? help me!

 
Sponsored Links
Joe_F's Avatar
Visiting Guest

Posts: n/a

02-20-03, 03:33 AM   #2  
Joe_F
We can't give you much help if you don't help us.

1) Which 4.3? There were 2 in this year.

2) When was the last time it saw any maintenance?

3) Is the check engine light on? Even if it's not, go to Autozone and have them pull any trouble codes.

etc, etc, etc, etc, etc, etc.

 
tpprr's Avatar
Visiting Guest

Posts: n/a

02-20-03, 08:37 AM   #3  
tpprr
jumping engine

the motor is a 4.3 tbi. hasnt had a tune up for some years now. oil has been changed regularly using synthetic. i did change the pcv valve, and air filter recently.maybe the gas filter needs to be replaced? check engine light is not on.

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

02-20-03, 09:09 AM   #4  
Joe_F
Replace all the filters and give it a complete tuneup. Start there first and see what that nets you .

 
tpprr's Avatar
Visiting Guest

Posts: n/a

02-25-03, 10:45 AM   #5  
tpprr
problem solved!! : the coil wire was loose. the end that plugs into the ignition coil was loose. once i pushed it back into the coil i took the truck for the drive and no more jumping. i am so happy!!

 
Search this Thread