Same Blower Speed on Two Settings, 1990 Corolla

Reply

  #1  
Old 04-19-03, 09:05 AM
sliderbot
Visiting Guest
Posts: n/a
Unhappy Same Blower Speed on Two Settings, 1990 Corolla

All of the sudden I have the same blower speed on two different settings, making me believe the connection in the blower switch has gone bad, and one speed isn't making a proper connection. I expect it could be the resistor, as well. I am wondering whether a bad resistor can really cause this problem. Any advice would be appreciated.
 
Sponsored Links
  #2  
Old 04-19-03, 09:11 AM
1fireman
Visiting Guest
Posts: n/a
Resistors are shot. Common problem, cheap fix. I don't know the exact layout of where the resistor is in this particular vehicle, but if it is located in the fresh air intake housing you may want to take your shop vac and clean any debris out of there. Leaves, dirt and other road debris pile up in there and is a fire hazard if it comes in contact with the resistor.
 
  #3  
Old 04-19-03, 11:27 AM
Join Date: Jun 2002
Location: Long Island, NY
Posts: 1,531
More likely bad blower sw, common on those years. If resistor is ng you will lose one or more speeds except hi, not have the same speed in two positions

Larry
 
  #4  
Old 04-19-03, 11:29 AM
Joe_F
Visiting Guest
Posts: n/a
I agree with Larry.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes