1990 Geo Prizm Light Indicator

Reply

  #1  
Old 06-23-03, 06:30 AM
Mike2002
Visiting Guest
Posts: n/a
Unhappy 1990 Geo Prizm Light Indicator

Hello,
I have a car Geo Prizm 1990,
starting couple days ago each morning a have a light indicator
show battery and brakes the same time. After I drive for a wile and stop on the intersection and drive again the lights are gone
at the same time, and not showing up for the rest of my driving.
What would be that?

Thank you.
 
Sponsored Links
  #2  
Old 06-23-03, 12:29 PM
Joe_F
Visiting Guest
Posts: n/a
Possibly a discharging alternator or you have two separate problems.

Do an alternator output check as I show it in my "The Basics" below.
 
  #3  
Old 06-24-03, 10:27 AM
Mike2002
Visiting Guest
Posts: n/a
Joe_F,
thank you for diagnostic advise.

I cleaned the battery posts, contacts, added water.
Mesured:
1. Voltage on the battery before car starts ~12.7V.
2. When car started it jumped to ~ 14.25 V, then was
changing from ~ 13.95 to 14.2 V.

Today in the morning had no warning sighns on the front panel.
I hope it was just contacts.

Thank you.
 
  #4  
Old 06-24-03, 10:51 AM
Joe_F
Visiting Guest
Posts: n/a
Your battery could be tired. I would pitch it for a maintenance free one if this is the case.

I haven't used a battery that needed water since I had my Moped in 1985. LOL.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes