4runner A/T oil temp light

Reply

  #1  
Old 06-30-03, 12:39 PM
Creede
Visiting Guest
Posts: n/a
4runner A/T oil temp light

I have a 1995 Toyota 4runner I purchased used. After about 30 miles at highway speed, the transmission oil temperature light comes on. If I slow down, 35 mph, for a few minutes, the light goes off. It looks like the transmission and transfer case have recently been removed and replaced. The radiator also looks like it is new. The transmission oil is clear and not burned.
Any ideas?
Creede
 
Sponsored Links
  #2  
Old 06-30-03, 12:43 PM
Joe_F
Visiting Guest
Posts: n/a
There's a sensor for the light which might be bad, but I'd change the fluid to be sure. Assume it was not done before you got it.
 
  #3  
Old 06-30-03, 12:58 PM
89blaze's Avatar
Member
Join Date: Jan 2003
Posts: 140
Check the fluid level. Low fluid will cause slipping and heat. If it has a tranny cooler, make sure the lines are hooked up and not capped.
 
  #4  
Old 06-30-03, 04:08 PM
Join Date: Jun 2002
Location: Long Island, NY
Posts: 1,531
Common problem with this trans if you use other than top quality fluid. We had this problem when they switched suppliers and thought they got a great deal on our bulk trans fluid. One by one they came back with ATM temp lites on.

Only if you drive 65-70 mph for 45 mins or more. Changed out with good name brand bottle fluid and problems gone.

Larry
 
  #5  
Old 06-30-03, 04:19 PM
Creede
Visiting Guest
Posts: n/a
Hi Larry
Thanks for the tip. Sounds like that is the best guess so far. Do you recommend a brand.? Did they switch from dextron ll on these? I think I heard some where that they had changed.
Thanks again.

Creede
 
  #6  
Old 06-30-03, 04:47 PM
Join Date: Jun 2002
Location: Long Island, NY
Posts: 1,531
It is Dextron III, any of the well know names: Castrol, Quaker State, etc

Larry
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes