Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

brakes


littlefitz's Avatar
Member

Join Date: Jul 2003
Posts: 20

07-02-03, 01:04 PM   #1  
brakes

I hope someone can help.I just had a front brake job on my 1993 Buick Century. Pads were replaced and rotors were turned. Car seemed to perform fine up to 45 miles per hour. At 45 mph or above, when you step on the brake pedal to slow down the steering column starts to shimmey. This only happens at high speeds and only when you depress the pedal lightly. If you apply force, the shimming stops. The car did not act this way before the brakes were serviced. Is this a problem with the brakes or something else? I have used the same mechanic for five years. Lately, every time I have my car serviced for a problem, I always have to return it for the same problem two and three times before it is corrected. I am thinking of changing mechanics. What do you think?

 
Sponsored Links
Joe_F's Avatar
Visiting Guest

Posts: n/a

07-02-03, 01:22 PM   #2  
Joe_F
The brake rotors are warped.

Frankly, throw them out and get new ones. Yes, they can be cut, but front drive rotors warp easily and are so cheap, it costs almost as much to cut them as it does to replace them.

Have the shop throw on new rotors for their cost of parts, nothing more. Make sure they use good US or Canadian made replacements such as Raybestos or Wagner.

 
skim35's Avatar
Visiting Guest

Posts: n/a

07-02-03, 01:28 PM   #3  
skim35
Yep. brake rotors are warped

replace with new

 
davo's Avatar
Member

Join Date: Apr 2002
Posts: 2,417

07-02-03, 01:49 PM   #4  
Wheels need to be torqued to avoid this problem.Hubs, in your case hub bearings can be damaged due to over or uneven tightening of the lug nuts.Another possibility is his lathe isn't the best or he doesn't clean rotors properly before resurfacing.If I were you I'd get 2 new quality rotors and replace them and torque the lug nuts.

 
littlefitz's Avatar
Member

Join Date: Jul 2003
Posts: 20

07-02-03, 02:12 PM   #5  
I want to thank everyone for their replies. Everyone I ask says its the rotors. I took the car back to the repair shop and the mechanic advises that my rotors are ok. He is blaming the problem on worn tires. He advised me to replace the tires, see what happens and then bring the car back to him if the new tires do not solve the problem. Before the brake job, I did not have this problem. If it were the tires, wouldn't I have had the problem all along? It only started after the brakes were serviced. Should I do as he asks or take it somewhere else and have my rotors inspected?

 
BelairBoy's Avatar
Visiting Guest

Posts: n/a

07-02-03, 02:22 PM   #6  
BelairBoy
take it somewhere else and get those rotors changed. Remember, most of the people on here are certified mechanics. Sounds like your mechanic is trying to get a couple hundred extra from you by getting you to buy tires when not needed. One good way to check the tread on your tires is. Take a penny and stick it in the tread(the little spaces)upside down. If they reach the top of lincoln's head, it's time to change em out for new ones. but as you stated, if tires were the problem it would have been happening before.

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

07-02-03, 03:08 PM   #7  
Joe_F
Switch the tires front to back. If you still have the problem (which you will) then have this guy eat the job for free.

His explaination cannot be logical. If the tires were wasted, you'd get a vibration all the time, not just when braking.

The rotors are warped or as Davo said, someone aped the wheel lugs on with an impact gun.

 
littlefitz's Avatar
Member

Join Date: Jul 2003
Posts: 20

07-03-03, 10:18 AM   #8  
I want to thank eveyone for their advice. The penny trick showed me that I do need tires. I did take my care back to the garage and they changed my front tires to the back and my back tires to the front but this didn't help.I still have the shimmy when I apply my brakes lightly at speeds of 50 mph or above. Under 50, I don't have the problem. If I apply more pressure to the pedal, the problem stops. When its happening it feels like the front tires are bouncing up and down. I am going to replace the tires because I need them but I feel like it's the rotors causing the problem. I am not going to take my car back to the garage that did the work because I have lost confidence in them. About three weeks ago they replaced the throttle position sensor. My car was idling very high and staying at speeds even when you didn't have your foot on the gas pedal. Even after they replaced the sensor, I still had the same problem. Then, they blamed it in the cruise control and disconnected it. I still had the same problem.It took them a week and a half to determine that the part was defective. Again, I want to thank everyone for their help.

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

07-03-03, 10:59 AM   #9  
Joe_F
Yea, time for a new shop. That one seems to be guessing at your problems.

Ask friends and relatives for reputable shop recommendations. You can also check the ASE website for good shops in your area. Choose ones that have few if any complaints with the local Better Business Bureau.

 
Search this Thread