1996 ford ranger

Reply

  #1  
Old 07-07-03, 12:21 PM
mawmaw
Visiting Guest
Posts: n/a
1996 ford ranger

need help with ranger that sat for 10 days in driveway. We had alot of rain but the truck never went thru any water, just sat in driveway. Now when starting the idle is awful, the truck shakes and then stalls. We smell gas. When finally starting we were able to take it down the street but still stalls when stopping. Could it be moisture? Where? thanks.
 
Sponsored Links
  #2  
Old 07-07-03, 12:35 PM
Joe_F
Visiting Guest
Posts: n/a
Engine size? Is the check engine light on? Mileage? When's the last time it saw service?
 
  #3  
Old 07-07-03, 02:45 PM
mawmaw
Visiting Guest
Posts: n/a
service 4mos. ago 96,000 miles 4cyl. everything changed at last service, belts hoses, etc.
 
  #4  
Old 07-07-03, 04:44 PM
Joe_F
Visiting Guest
Posts: n/a
Pull off the hose on the fuel pressure regulator and see if fuel comes out of it. If so, wasted regulator.
 
  #5  
Old 07-08-03, 02:55 PM
mawmaw
Visiting Guest
Posts: n/a
Confused over having fuel injection or not

if not, what is it?
 
  #6  
Old 07-08-03, 11:58 PM
Visiting Guest
Posts: n/a
maybe some moisture condensed inside the dist. cap(if the truck has one), maybe the cap wasn't seated correctly, maybe moisture got on the plug wires, or near the plugs, try drying all parts of the ignition system off if you think it's a problem due to the rain, when it's 100% humidity, moisture gets everywhere!


a totally different car than this i had would leak rain into the computer if i parked it at a certain angle, car would run like crap for a day or two, unless i got mad enough to take it out and dry it with some compressed air
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 06:25 PM.