All my coolants leaking out, hissing noise when Engine is running

Reply

  #1  
Old 07-21-03, 10:36 AM
Spursfan
Visiting Guest
Posts: n/a
All my coolants leaking out, hissing noise when Engine is running

I have a 1990 Pontiac Sunbird LE 2.0L. Lately, I have been refilling coolant after every drive. When I stop, it all leaks out, and there's a hissing sound when the engine is on. The temperature gauge still gives me normal readings but I guess that's because I refill often. I checked under the car after an overnight park and realize that the leak emanates from the left front side, a bit behind the radiator. Can you please help me identify the problem area and possibly fix it? Thanks.
 
Sponsored Links
  #2  
Old 07-21-03, 11:05 AM
Joe_F
Visiting Guest
Posts: n/a
When's the last time the cooling system saw any service such as new radiator hoses and clamps? You could have a leaky radiator.

Any shop can do a cooling system pressure test on this and advise you of the leak and the needed repairs. Shouldn't be hard to do in most cases.
 
  #3  
Old 07-21-03, 11:43 AM
Spursfan
Visiting Guest
Posts: n/a
actually..just replaced the hose and clamps

Thanks again Joe
The radiator hose had a leak and I replaced that along with new clamps. The problem began a few days after I installed the new hose. First, I noticed coolant leaking from the pressure cap and after I tightened the cap to its recommended orientation(with the arrows aligned to the hose)...the leak moved to some other place that I have yet to identify. I'll try the cooling system pressure check that you recommended. See if this new info will add something to what you said.
 
  #4  
Old 07-21-03, 11:51 AM
Joe_F
Visiting Guest
Posts: n/a
Throw the cap out and get a new one, it sounds shot. A couple of bucks and cheap insurance.

Try that and let's go from there.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes