94 Pontiac injectors not delivering fuel

Reply

  #1  
Old 08-03-03, 11:29 AM
StriderS
Visiting Guest
Posts: n/a
94 Pontiac injectors not delivering fuel

Recently my 94 Grand Prix 3.1 L started dying momentarily. The clock would reset and the in the radio and fan would go off. If it died at a stop I would have to restart the engine, if driving down the road at speed the engine would restart. Now the engine has died and will not restart. When I try to start it the engine, it will turnover but will not start. When the key is turned on the clock does not come on and interior lights do not work. The headlights will work but the engine will not start. I have changed the fuel filter and there is fuel at the rails but the injectors don't seem to be working. In addition, there is spark to the plugs. It seems to me that the injectors are not working for getting power to them. Have checked fuses and battery. Seems like a elec relay or connection but where?
 
Sponsored Links
  #2  
Old 08-03-03, 04:15 PM
Joe_F
Visiting Guest
Posts: n/a
Sounds like a bad electrical problem.

I have seen bad alternators cause funny problems. Suggest you have it bench tested and checked out.
 
  #3  
Old 08-03-03, 05:29 PM
StriderS
Visiting Guest
Posts: n/a
Thanks Joe

I'll give it, a try thanks for the reply
 
  #4  
Old 08-03-03, 10:41 PM
knuckles
Visiting Guest
Posts: n/a
The injectors are powered through the F/INJ fuse in the underhood electrical center. Check for power to the PINK wire at each injector.

If you have power, yet the injectors still won't work, check for correct CKP input to the PCM. Good signals from both CKPs and a good CMP signal=bad PCM or no power or ground to PCM.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes