Rough Idle

Reply

  #1  
Old 08-18-03, 06:31 AM
Member
Thread Starter
Join Date: Jul 2003
Location: New Orleans
Posts: 20
Rough Idle

Guys I need your help again. I have the 1993 Buick that had a water pump and harmonic balancer replaced. Car was running rough and making a whining noise. Started acting up while I was out of town. I left it in Jackson Ms. to be repaired. I live in New Orleans. Drove back this weekend to pick it up. The water pump was replaced ( this took care of the whining noise) and the harmonic balancer was replaced because it was losing its rubber. The car is still running rough and making a low knocking noice. The idle goes up and down but car runs smoothly once you start moving at a speed of about 20 mph. The knocking noise seems to be coming from the area of the power steering reservoir. I noticed that there are a number of pulleys in this area that the serpentine belt (this was replaced) wraps around. I think the mechanic over looked the problem.I don't blame him, however, because I am sure he thought he corrected the problem by replacing the water pump and the harmonic balancer. Could the harmonic balancer be defective? One thing that does concern me is that the harmonic balance only cost $96.00. I thought that it ran around $170.00 for this part? Do you think I have another problem or was something not done correctly or do I have a defective part? I appreciate your help.
 
Sponsored Links
  #2  
Old 08-18-03, 06:33 AM
Joe_F
Visiting Guest
Posts: n/a
The crank sensor may have been damaged, was it replaced?

Also, he may have used an aftermarket balancer---myself, I'd only go with a GM part.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes