Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

squeaky serpentine belt at startup


clausen11's Avatar
Visiting Guest

Posts: n/a

08-29-03, 02:34 PM   #1  
clausen11
squeaky serpentine belt at startup

i have a 1992 saturn sl2 1.9 liter DOHC with a squeaky serpentine belt at startup.

i don't think it's the belt because it only squeaks for about a mile or so, not for the whole time the engine is running.
it seems as though the squeak gets worse as more electrical accecories are turned on such as the A/C, blower, headlights etc.
i think a worn out belt would squeak for the whole time the engine is running.

how do i fix the squeak?

 
Sponsored Links
YamahaWolverine's Avatar
Member

Join Date: Dec 2002
Posts: 162

08-29-03, 02:58 PM   #2  
It's probably the belt. Shoot a little penetraiting oil on it when it's squealing. If the noise goes away you know it's the belt. And replace it.

 
billys68ss's Avatar
Member

Join Date: May 2003
Posts: 1,459
WV

08-29-03, 07:41 PM   #3  
Kinda depends on the squeak. You could have a squeaky tensioner. They will squeak for a bit and then stop once they warm up as will a belt. If the belt dressing doesnt quieten the squeak then try to direct a little of it into the tensioner and the other pulleys one at a time.
Hope this heps ya,
Billy

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

08-30-03, 03:39 AM   #4  
Joe_F
Saturn had a bulletin on a bad idler pulley some time ago---check Alldata.com. The dealer ate our repair under warranty from what I remember.

The fix is a new belt and revised idler pulley. See the Saturn parts counter guy for additional bulletin details.

 
Search this Thread