Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

1995 Ford Explorer 4x4


dave6466's Avatar
Member

Join Date: Sep 2003
Posts: 757
PA

09-14-03, 11:30 AM   #1  
1995 Ford Explorer 4x4

Hi,
Ford Explorer 1995 4x4 auto, V6, 4.0.
O.D. off light on dash won't go off. Tried pushing in on end
of gear shift button. Still won't turn O.D. on. If I turn engine
off & turn key to the acc. position without starting motor I can
turn O.D. on & off with the button on end of gear shift arm. As
soon as I start motor, O.D. off light comes right back on. Had the
master cylinder replaced about 2 months ago. Guessing that
won't have anything to do with O.D. though. Another thing I
noticed since this happened, anti-lock brakes seem to kick in
even if not making a hard, quick stop. Possibly related problem?
Sounds like another appt. at local Ford garage
Any ideas on what to check would be appreciated.
I know......trade it in for a Chevy. Heard that one before. Lol.
Thanks Dave

Also, took it for a ride and the O.D. did'nt kick in at 50 mph.

 
Sponsored Links
Joe_F's Avatar
Visiting Guest

Posts: n/a

09-14-03, 11:33 AM   #2  
Joe_F
Too late to trade it in for a Chevy, knee deep in this one already. LOL

Have you taken a look at the OD button? First place I'd start. Second is to check alldata.com for any bulletins on your problems.

 
dave6466's Avatar
Member

Join Date: Sep 2003
Posts: 757
PA

09-14-03, 12:12 PM   #3  
Hi Joe
Checked alldata.com. No bulletin on this problem.
I don't think it is the O.D. switch, button on the end of shift
lever because I can make the O.D. dash light go on & off by
pushing it when the ignition switch is in the acc. position. As
soon as I start engine the dash O.D. off light comes on and
then I can't turn it off by pushing the button on shift lever.
Dave

 
dave6466's Avatar
Member

Join Date: Sep 2003
Posts: 757
PA

09-14-03, 04:16 PM   #4  
By the way the O.D. off light is flashing on & off on the dash.
Not staying on all the time as stated before.

 
Search this Thread