Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Mercury Cougar XR7 1996


thickey1's Avatar
Visiting Guest

Posts: n/a

09-22-03, 03:39 AM   #1  
thickey1
Mercury Cougar XR7 1996

Mercury Cougar XR7 1996 Have a 4.6 litre V8 with check engine light comeing on. This happened just after the engine was degreased and hi pressure washed. The car runs rough for a while like a car would run when there is water in the gas tank then runs fine after warms up. Still have check engine light on

Thanks in advance,

 
Sponsored Links
billys68ss's Avatar
Member

Join Date: May 2003
Posts: 1,459
WV

09-22-03, 04:08 AM   #2  
Put a scanner on it and find out what the codes are. This will narrow your search. You may have knocked a vacuum line or electrical connector off. Worse case, you broke or damaged something. Let us know what your codes are.
Billy

 
toyotaman11769's Avatar
Member

Join Date: Jun 2002
Posts: 1,531

09-22-03, 08:25 AM   #3  
Sounds like wires are wet, most likely water in the spark plug holes.

Larry

 
darrell McCoy's Avatar
Visiting Guest

Posts: n/a

09-22-03, 09:58 AM   #4  
darrell McCoy
I'd drive it a while, then check codes and reset light, will probably be OK. Pressure washing engines with electronic stuff is bad business.

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

09-22-03, 07:00 PM   #5  
Joe_F
All are correct.

Tip: No need to steam clean an engine like this. Not a show car and doing so does more harm than good for the everyday car. Leave it be .

 
Search this Thread