Charging system for 1982 Toyota Pickup


  #1  
Old 10-06-03, 09:50 AM
liltrucker
Visiting Guest
Posts: n/a
Charging system for 1982 Toyota Pickup

Two weeks ago the charge light on my dash lit up. The voltmeter was reading about 11 and a half volts. Normally I would see the voltmeter reading about 13 volts. I have replaced the alternator,voltage regulator and installed a new batery. The charge light is still lit and the voltmeter still reads about 11 and and a half volts. I turn on the head lights and the voltmeter drops to about 11 volts even, turning off the lights the voltmeter returns to about 11 and a half. Did I get a bad alternator or regulator or is there some other little piece of equipment I am overlooking? The engine in the truck is a 22R 4 cyl. The truck is the 2 wheel drive model long bed.
 
  #2  
Old 10-06-03, 09:54 AM
Joe_F
Visiting Guest
Posts: n/a
There may be a fusible link in the charging system which is blown and you have overlooked.

Get a wiring diagram and look closely at the charging system, see if you missed something.

Also, many aftermarket off the shelf rebuilds are of poor quality, so that is a possibility too.
 
  #3  
Old 10-06-03, 01:09 PM
Join Date: Jun 2002
Location: Long Island, NY
Posts: 1,491
Upvotes: 0
Received 0 Upvotes on 0 Posts
Seem to remember maybe a charge fuse in the dash fuse panel. I think these were the glass type fuses. The jap fuses had a habit of cracking, look good to the eye so check with a test light.

Larry
 
  #4  
Old 10-06-03, 01:14 PM
Joe_F
Visiting Guest
Posts: n/a
Or simply change the fuse for a whopping 50 cents . LOL.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: