Low Idle

Reply

  #1  
Old 10-09-03, 07:55 PM
wscall
Visiting Guest
Posts: n/a
Low Idle

I have a 1996 Mazda B3000 truck with 107,000 miles on it. Normally, when I crank it, it idles at about 1500 rpms and then levels out to about 1000 rpms. Lately, when I crank it, it drops down to about 500 rpms and shuts off if I don't keep it reved up with he accelerator. After a few minutes it will stay reved up to about 1000 rpms but idles kind of rough. It drives fine once it warm up. If I let it sit for a few hours, it idles low again when I start it. Would it help to have the codes read if it only happen when it's cold because the truck will be hot by the time I get it to someplace like autozone?
 
Sponsored Links
  #2  
Old 10-10-03, 04:38 AM
Joe_F
Visiting Guest
Posts: n/a
Some Fords (this is really a Ford Ranger in disguise) have had problems with the IAC and dirt in the throttle body, so the problem could be here (or a vacuum leak).

Sure, getting the codes is a start. Post what they find here.
 
  #3  
Old 10-17-03, 06:08 PM
wscall
Visiting Guest
Posts: n/a
Talking

I cleaned both the IAC and the throttle body and it fixed the problem. Thanks for all your help.
 
  #4  
Old 10-18-03, 08:04 PM
Joe_F
Visiting Guest
Posts: n/a
Good job!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes