1988 Cavalier Speedometer

Reply

  #1  
Old 10-16-03, 07:54 AM
TMC
Visiting Guest
Posts: n/a
1988 Cavalier Speedometer

I need help with my daughters car. 1988 Cavalier. automatic.
The speedometer started acting strangley yesterday. The speedodmeter needle jumps from one speed to another while driving at a steady speed. The needle is very jumpy. How do I resolve this problem? Also the dash light on the speedometer is not working. Could this be a blown fuse? I appreciate any info you can provide. Thank You.
 
Sponsored Links
  #2  
Old 10-16-03, 07:58 AM
Joe_F
Visiting Guest
Posts: n/a
Blown fuse, burned out light bulbs, all posssibilities.

Sounds like a worn/bad/dirty/out of lubrication speedo cable on the jumpy speedo.

I drive an '89 version of this same car, 2.0. So-so econobox....
 
  #3  
Old 10-16-03, 02:15 PM
Member
Join Date: Aug 2003
Location: Barre,Vermont
Posts: 472
HMMM....DOES THAT CAR HAVE A SPEEDO CABLE? I WONDER WHAT MOTOR IT'S GOT....
DO THE LIGHTS FOR THE RADIO DIM WHEN TURNING ON THE HEADLIGHTS? I ASSUME U ARE TALKING ABOUT THE LIGHTS THAT ILLUMINATE THE SPEEDO AT NIGHT? DO THE LIGHTS FOR THE HEATER CONTROLS COME ON WITH THE HEADLIGHTS?
 
  #4  
Old 10-17-03, 06:52 AM
Joe_F
Visiting Guest
Posts: n/a
I know that when I looked up an 88 Cavalier 2.0 yesterday in the EDS Imager, it showed a Delco CC1021 cable for this for all except digital dash.

I haven't seen many 2.0 liter Cavaliers with digital dash (most were 2.8 Z24's).
 
  #5  
Old 10-17-03, 07:44 AM
Member
Join Date: Aug 2003
Location: Barre,Vermont
Posts: 472
Smile

SO JOE, THROUGH TELEPATHY YOU FIGURED OUT IT'S NOT A Z-24?
 
  #6  
Old 10-17-03, 08:14 AM
Joe_F
Visiting Guest
Posts: n/a
You're right, I guess I shouldn't have to repeat myself and say,

FOLKS. YOU MUST POST YEAR, MAKE, MODEL, ENGINE SIZE AND ALL VEHICLE DETAILS IF WE HAVE ANY CHANCE TO HELP YOU OUT.READ THE STICKY AT THE TOP OF THE FORUM'S PAGE ****BEFORE***** YOU POST!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Bearing that in mind, we do not know what type of Cavalier or engine size.

With that being said, the 2.8 liter engine also uses a cable. Only the digital dash equipped vehicles do not.

Perhaps we can assume the poster has the majority, which would be an analog cluster that would have a cable.

Dead issue until the original poster furnishes additional details
 
  #7  
Old 10-20-03, 01:32 PM
TMC
Visiting Guest
Posts: n/a
Thank you all that replyed! It's a 1988 Cavalier not a Z model. Basic cavalier. 2.0 motor. Not a digital dash. everything else is fine. Just the jumpy speedo needle and the light out on the speedo side. Thanks for your reponses.
 
  #8  
Old 10-20-03, 04:54 PM
Joe_F
Visiting Guest
Posts: n/a
And it DOES have a cable because I saw mine this weekend on my '89 2.0 Cavalier while doing the heater hoses .

Likely cause of the problem.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes