Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

1999 Ford Expedition dies


Biobus's Avatar
Visiting Guest

Posts: n/a

11-02-03, 12:35 PM   #1  
Biobus
1999 Ford Expedition dies

My 1999 Ford Expedition (5.4L) keeps dying when I start it. It starts, then dies quickly unless I rev up the engine. As soon as I quit giving it gas, it dies. I am able to give it gas, then quickly put in gear to drive, but it did die last night as I was turning into the driveway. Anyone know what might be the problem?

Thanks,
Steve

 
Sponsored Links
bejay's Avatar
Member

Join Date: Dec 2001
Posts: 2,538

11-02-03, 10:55 PM   #2  
start by having codes read autozone can likely retrieve codes for you so can most shops.
check for vacum leaks a large vacum leak could cause this problem check the vacum line near the back of the intake common place to develop a leak, could also be an idle air control valve problem also.

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

11-03-03, 04:43 AM   #3  
Joe_F
I agree.

 
Biobus's Avatar
Visiting Guest

Posts: n/a

11-03-03, 10:21 AM   #4  
Biobus
Had to take it into the shop, as wife was needing it faster than I could get it done. The mechanic ran the diagnostics and tells me the idle control motor needs to be replaced, which seems to be inline with your thoughts. ($180 for parts & labor)

Thanks for the help.

Steve

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

11-03-03, 10:23 AM   #5  
Joe_F
Let us know the outcome.

 
kerry's Avatar
Member

Join Date: Sep 2003
Posts: 506
TX

11-04-03, 06:21 AM   #6  
that must be a common problem with that year model. our 99 did the same thing, but it was off and on. not a continuous problem. we traded it in before finding the problem. i personally did not like the sensitive steering. i thought it was unsafe. other than that, it was a great car.

 
Biobus's Avatar
Visiting Guest

Posts: n/a

11-05-03, 04:30 PM   #7  
Biobus
Replaced the Idle Control Motor and everything is working great.

Thanks for the help.

 
helpful's Avatar
Visiting Guest

Posts: n/a

11-05-03, 04:49 PM   #8  
helpful
Re: 1999 Ford Expedition dies

Originally posted by Biobus
My 1999 Ford Expedition (5.4L) keeps dying when I start it. It starts, then dies quickly unless I rev up the engine. As soon as I quit giving it gas, it dies. I am able to give it gas, then quickly put in gear to drive, but it did die last night as I was turning into the driveway. Anyone know what might be the problem?

Thanks,
Steve
------ Yes, The problem is your fuel filter, Change that first, it's gone bad

 
Biobus's Avatar
Visiting Guest

Posts: n/a

11-05-03, 04:54 PM   #9  
Biobus
didn't need to change the fuel filter, it was the idle control motor

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

11-06-03, 07:22 AM   #10  
Joe_F
Help:

How do you know it's the fuel filter?

 
Search this Thread