96 Mustang Cobra cant keep cool

Reply

  #1  
Old 11-03-03, 11:37 AM
nikkijohn_99
Visiting Guest
Posts: n/a
Unhappy 96 Mustang Cobra cant keep cool

I have a 1996 Ford Mustang Cobra, 4.7 ltr, V8, 5 speed manual tranny, w/100k miles. The problem: check engine light stays on constantly, overheats with 5-7 minutes of normal driving, A/C not working. I have had 2 diagnostics(showing cause to be a worn fan motor and ECT sensor), a compression test (normal), and the radiator flushed and checked (OK). I have replaced: the entire fan assembly, thermostat, water pump, ECT sensor, plugs, wires, & freon is charged. I am now being told that the cause(s) could be wiring, blown head , clogged catalitic converters, etc., etc.??? What do I do now?? I have already spent way too much money and can't afford any more maybe's. PLEASE HELP!
 
Sponsored Links
  #2  
Old 11-03-03, 12:42 PM
darrell McCoy
Visiting Guest
Posts: n/a
Before I spent anymore coins, I would get a combustion check.
Getting hot that quick, sounds like combustion gas getting into coolant system.
 
  #3  
Old 11-03-03, 07:37 PM
mike from nj
Visiting Guest
Posts: n/a
a check engine light means you have something stored as a code, try starting with that, post it here and hopefully someone will help you. everything could be related to one problem, hopefully
 
  #4  
Old 11-04-03, 09:41 AM
Joe_F
Visiting Guest
Posts: n/a
Sounds like it's time for another mechanic.

As Darrell alludes to, a blown gasket can easily be checked with a cooling analyzer or gas analyzer. This will confirm any problems here.

Are any air dams missing underneath? If they are, or are damaged, replace them, this will cause overheating in a jiffy.

Also, is the vehicle stock? If you have those "underdrive" pulleys that "enhance" performance, throw them out and put the stock ones back, those pulleys are more problems than they are worth.


BTW: This has a 4.6, not a 4.7 .
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes