Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Turn Signals Don't Work!


DEXTERDOG's Avatar
Visiting Guest

Posts: n/a

11-06-03, 12:13 PM   #1  
DEXTERDOG
Turn Signals Don't Work!

Can someone tell me what to check next? The turn signals on a 1987 Honda Accord aren't working. I have replaced the fuse and two faulty bulbs and nothing happens when I use the turn signal. No lights, no clicking, no nothing. HELP!

 
Sponsored Links
Joe_F's Avatar
Visiting Guest

Posts: n/a

11-06-03, 12:16 PM   #2  
Joe_F
Do the hazards work OK? If they do, bad flasher/turn signal relay more than likely.

 
DEXTERDOG's Avatar
Visiting Guest

Posts: n/a

11-06-03, 12:37 PM   #3  
DEXTERDOG
TURN SIGNALS

I just checked and the hazards don't work either. Tell me it's not something electrical.

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

11-06-03, 12:52 PM   #4  
Joe_F
Assuming the grounds throughout the system are good, you may have a bad turn signal switch.

 
mike from nj's Avatar
Visiting Guest

Posts: n/a

11-06-03, 10:38 PM   #5  
mike from nj
i would be thinking more along the lines of a bad blinker/flasher relay. most jap cars only use one for both turn signals and hazards.

if the hazards worked, then i would say the flasher would be ok.

since your hazards don't work, i'd be looking at a wiring diagram to confirm that your particular car only has ONE flasher serving a dual function( turn signals and hazards)

(opposite to most american cars)

 
Search this Thread