Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

1995 Pontiac Transport


brenh05's Avatar
Visiting Guest

Posts: n/a

11-14-03, 01:14 PM   #1  
brenh05
1995 Pontiac Transport

Have a 95 Pontiac transport..It's a 3.1 liter. Has about 69K miles.
Have done a complete tune-up on it. There are a couple problems
with it. First of all at around 50-52 MPH, it bogs down for a couple secs like it is losing power and then picks right back up.
I also have a 92 Transport that does the same exact thing and no one figured out why it did it. Had it put on the analyzer too.
Secondly, the 95's check engine lite comes on and the code is 45.
According to the manual that I bought for it, it is running too rich.
Have already replaced the 02 sensor a month ago. Any ideas??
Thanks in advance.

 
Sponsored Links
davo's Avatar
Member

Join Date: Apr 2002
Posts: 2,417

11-14-03, 02:27 PM   #2  
You need to correct the rich mixture first.Things to check are air filter,fuel pressure,injectors for leaks and maybe clean the mass air flow sensor.When checking the fuel pressure also leave the guage on for about 10 minutes with the engine off.This will help determine if the injectors or fuel pressure regulator are leaking,Do this and post your findings.

 
brenh05's Avatar
Visiting Guest

Posts: n/a

11-15-03, 08:16 AM   #3  
brenh05
Davo,

Got a question though..I understand all the other things that
you said but according to the manual, my van doesnt have a
MAF sensor, but the MAP sensor. Where would the MAF be, if it
has one??

 
davo's Avatar
Member

Join Date: Apr 2002
Posts: 2,417

11-15-03, 12:53 PM   #4  
Between the air filter housing and the throttle body in the air intake hose.Your van should have both sensors MAF and MAP.What manual are you using?

 
brenh05's Avatar
Visiting Guest

Posts: n/a

11-15-03, 01:28 PM   #5  
brenh05
Haynes manual..for 1990 thru 1995

 
Search this Thread