Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Anyone had this problem before??


Stan58's Avatar
Visiting Guest

Posts: n/a

12-30-03, 01:51 AM   #1  
Stan58
Anyone had this problem before??

I have a 1987 Chevy S10 Tahoe And the Idle is too fast.

The truck runs good in every respect other than that.

It has a 2.8 V6 with auto transmission, PB,PS,AC.

When the engine is first started It idles fast and then slows slightly but not enough to keep it from lurching pretty hard when put in gear.

It has a throttle body injected carb and I cant seem to find an idle screw.

Do these have a fast idle modual that can go bad or something?

All help appreciated.Thanks in advance.

Stan

 
Sponsored Links
Desi501's Avatar
Member

Join Date: Oct 2003
Posts: 2,207

12-30-03, 02:37 AM   #2  
The idle is computer controlled and not adjustable. You need to check for vacuum leaks and also scan computer and check temp sensors.

 
Stan58's Avatar
Visiting Guest

Posts: n/a

12-30-03, 04:23 AM   #3  
Stan58
Thanks Desi501.

 
davo's Avatar
Member

Join Date: Apr 2002
Posts: 2,417

12-30-03, 04:27 AM   #4  
Check the gasket under the tbi unit very common to find them leaking.I spray carb cleaner at suspected leak sources with the engine idleing,if the rpms change you've found the leak.Don't spray near the exhaust manifold or plug wires because it's flammable.

 
Stan58's Avatar
Visiting Guest

Posts: n/a

12-30-03, 05:03 AM   #5  
Stan58
Thanks davo.

 
Search this Thread