Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

94 gmc 4.3 t/b no fuel


reyes45's Avatar
Member

Join Date: Mar 2003
Posts: 71
MI

01-20-04, 11:28 AM   #1  
94 gmc 4.3 t/b no fuel

I had problems with the truck so I changed the fuel pump and filter and now I got no fuel delivery to the throttle body. I checked the fuse and changed the fuel pump relay and still I got no fuel. What else could be the problem? Plaese help. Thanks.

 
Sponsored Links
davo's Avatar
Member

Join Date: Apr 2002
Posts: 2,417

01-20-04, 02:46 PM   #2  
What kind of problem did you have?Did you have fuel pressure prior to replacing the pump?Have you checked fuel pressure now with the new parts?While your at it will it fire on starting fluid or carb cleaner?

 
reyes45's Avatar
Member

Join Date: Mar 2003
Posts: 71
MI

01-21-04, 04:23 PM   #3  
At firsr it would pull and tug going down the road. But after I changed the parts it ran good for about 60 miles and all of a sudden it quit from being at idle. Now I get no fuel. It will start with starting fluid. You think maybe I got a difective pump.

 
darrell McCoy's Avatar
Visiting Guest

Posts: n/a

01-21-04, 04:58 PM   #4  
darrell McCoy
I know OEM pumps are pricey, but you get better quality. Regardless of expense I use them as I dont like to do the job twice. Did you use a O.E.M. Part? Some of the store brand are not worth the time and effort.

 
davo's Avatar
Member

Join Date: Apr 2002
Posts: 2,417

01-21-04, 05:04 PM   #5  
Check for power and ground at the pump connector. If you have both the new pump may be bad or the terminals in the connectors are burned(very light brown)or spread apart slightly causing the pump to not operate.I hope you have gas in the tank.

 
Search this Thread