Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Heater Malfunction


SteelPanther's Avatar
Visiting Guest

Posts: n/a

01-22-04, 12:57 PM   #1  
SteelPanther
Heater Malfunction

1992 Isuzu Rodeo 3.1 V6 4x4 auto trans.

Last night I went to the gas station and everything worked fine with the heater. Then today I hopped in and started it up and no fan. I messed with the controls thinking maybe somethign was just caught in between switches no luck. So I left ti running because the fan wont run unless the engine is on in these models and pulled off the wires to the fan motor under the dash. Upon testing there was no power going to the fan motor. Checked the fuses, all good. Checked and swapped out the relays under the hood and those worked fine as well.

I want to take out the heater control panel from the dash to test the switch but I dont know how to get it out of the dash and the Chiltons manual I have for the vehicle doesnt have a section describing how to remove the heater control panel. If someone could help with telling me how to remove the heater controls id be very grateful also any other things to check. thanks.

 
Sponsored Links
SteelPanther's Avatar
Visiting Guest

Posts: n/a

01-22-04, 06:13 PM   #2  
SteelPanther
Managed to unplug the wiring from the back of the heater by reaching through glove compartment hole. Upon testing these wires I cant seem to find any that have any juice in them. (vehicle was started) Any Ideas?

 
Desi501's Avatar
Member

Join Date: Oct 2003
Posts: 2,207

01-22-04, 06:37 PM   #3  
If it's not ATC then they usually use a resister block to change speeds. It's generally wired to the ground side with power to the motor all the time. Since you don't have any power to the motor, you need to look for fuses or possibly a fusable link. Now, if you have automatic temp control, it's a whole different story with some extra modules doing the controlling. A schematic for the system is usually a must before doing any troubleshooting.

 
SteelPanther's Avatar
Visiting Guest

Posts: n/a

01-22-04, 07:04 PM   #4  
SteelPanther
No I dont think it is ATC just a old fashion type heater nothing fancy. The resistir block would be what is under the fan speed switch correct? If so there is no power whatsoever to the heat control unit with the exception of the lights which are attached to the trim panel. But i basically pulled off all the plugs off the back of the control unit and tested them in various cominations with no power result.

 
mike from nj's Avatar
Visiting Guest

Posts: n/a

01-23-04, 12:04 AM   #5  
mike from nj
atc wasn't even a thought in 92

no, the resistor block is screwed into the heater box, and right behind the glove box, a few simple screws and you can see it.

why would you want to?? like you were already told, the power for the entire system comes through the blower motor. the switch and the resistor are on the ground side of the motor.

you need to establish power to the motor, which should be fed by a relay and a fuse under the hood.

before you do anything, check the battery voltage while idling. is it 12 volts or 14 volts? a reading to the first decimal point will do.

if it's not charging, you won't have a blower motor either

 
Search this Thread