Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

No Control Over the Horn!!!


raymo8's Avatar
Visiting Guest

Posts: n/a

01-26-04, 10:47 AM   #1  
raymo8
No Control Over the Horn!!!

1992 Pontiac GrandAM
4 cyl, 2.3 Liter DOHC
63,000 miles

Recently the horn on my car will just randomly start blaring. I can't turn it off unless I pull the fuse or disconnect the battery. Sometimes it happens when I'm driving and sometimes it happens when the car is parked and completely turned off (usually in the middle of the night when I'm sleeping! Then I have to run outside in the cold and fix it). Does anyone know what the problem could be?

 
Sponsored Links
goldstar's Avatar
Forum Topic Moderator

Join Date: Oct 2002
Posts: 4,286
OH

01-26-04, 02:14 PM   #2  
If it is happening only in cold weather, I would suspect the horn switch. I had this happen when the car would get really cold - as in parked outside in freezing weather. The cold caused one of the contacts to touch ground and that would set off the horn. It was an easy fix on a pre air bag car, but I can't tell you how to cure it on yours. Maybe pray for warm weather.

 
Desi501's Avatar
Member

Join Date: Oct 2003
Posts: 2,207

01-26-04, 03:43 PM   #3  
It is most likely the horn switch but if you have an air bag don't try to fix it yourself. It could explode in your face. If you don't have an air bag then just remove the horn cover which usually has the switch inside and unplug the one wire. You'll have to go to the dealer for a new one.

 
raymo8's Avatar
Visiting Guest

Posts: n/a

01-27-04, 06:54 AM   #4  
raymo8
Thanks for the advice. Unfortunately it happens in all kinds of weather...even in the summer when it gets up from 80-100 degrees. (I live in NJ). I think that it's the horn switch too, but I think that it is somehow stuck or grounded out permanently (not just from the cold.) Just yesterday I tried putting the fuse back in and it instantly started blaring again.

Fortunately, the car doesn't have an airbag either. I took the steering wheel cover off and unplugged the single wire from its brass contact. There was no switch there though...it was just a single red 16 gauge wire (about 2-3 inches long) with a male and female connector that ran further down into the steering column. That is what I unplugged and it didn't solve the problem because I think it's deeper somewhere in the steering column. Could the horn switch be located somewhere else? I'm not sure what it looks like and where it may be located.

 
goldstar's Avatar
Forum Topic Moderator

Join Date: Oct 2002
Posts: 4,286
OH

01-27-04, 01:15 PM   #5  
Okay, the next item to check is the horn relay. It shoud have three connectors. One is from the horn switch , one is from the battery, and one goes to the horn. With the horn switch disconnected at the steering wheel, but the fuse plugged in, you can use a voltage tester or 12v light to test the relay. The connector from the switch should show 12 volts, the battery connection should have 12v and the horn connection should have no voltage.
If the horn connector shows 12v ( horn is blowing ) , disconnect the wire from the horn switch at the relay. If the horn continues to blow, the relay is bad. If the horn stops, you have a short between the horn switch and the relay.

 
raymo8's Avatar
Visiting Guest

Posts: n/a

02-07-04, 11:39 AM   #6  
raymo8
Goldstar---Sorry for taking so long to get back...i haven't been able to find time up until now to look at it.

I took the plastic cap off the steering wheel and found what I suppose is the connector that you said to test. I put the fuse in and tested it and it read 12v. I guess this meant that the horn would have been blaring.

I then couldn't disconnect the wire from the horn switch at the relay. I don't know what the horn switch looks like and I may not be able to get to it.

I found it interesting though that the horn will not sound at all now. When I hit it, I hear some clicking inside of the relay.

 
goldstar's Avatar
Forum Topic Moderator

Join Date: Oct 2002
Posts: 4,286
OH

02-07-04, 02:43 PM   #7  
The wire at the steering wheel should show 12V. Pushing the switch grounds it . That energizes a coil in the relay which then feeds 12V to the horns.

If you can have someone hold down the horn switch or ground the wire while you are under the hood, listen for a single click each time they push the switch. If you get a click, the relay is pulling in. With the horn button pushed, you should read 12V on the horn wire connection.

If the relay is pulling in, and you have 12V at the horn wire connector, the horn should blow. If not, test for 12V where the wire actually connects to the horn. Again, have someone hold the button down while you check. If you have 12V there, You may have burned out the horn through prolonged blowing.

If the relay clicks in, but you don't have 12V at the wire conntor on the relay, it is probably bad.

 
Search this Thread