my 92 grand marquis

Reply

  #1  
Old 01-26-04, 06:21 PM
jodes
Visiting Guest
Posts: n/a
my 92 grand marquis

I'm trying to figure out what's wrong with my girlfriends car. The rear end is sitting very low to the ground. The rear tires almost touch the wheel well. The air ride suspension light stays on and I've tried shutting it off and turning it back on to reset it, but it doesn't work. My mechanic worked on the car and didn't turn the air ride off, and ever since then it has not worked properly. He doesn't know anything about the air ride. I checked a repair book and it sounds like it might be the sensor unit that tells the car to put air in the rear but I'm not sure any input would be greatly appericiated. Thank you.
 
Sponsored Links
  #2  
Old 01-26-04, 07:30 PM
hogfan's Avatar
Member
Join Date: Oct 2003
Posts: 352
Check the fuses under the hood,there is one for the air ride system. If it is blown you could have air bag problems with a bad compressor due to it over running tring to air up the bags. Sometimes I have seen water enter to compressor motor switches and short them out blowing the fuse. I hope this helps.
 
  #3  
Old 01-27-04, 03:45 AM
Desi501's Avatar
Member
Join Date: Oct 2003
Location: Boynton Beach Florida
Posts: 2,207
First, find out if the compressor is running with the key on. If it is then check your bags to see if the broke their seal. If you compressor is not running, it may have burned up. You can pull codes on the system but I think you need a "Star tester".
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes