Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Fast Flasher on Left turn 2001 F150 4X4


aaron_eckhoff's Avatar
Visiting Guest

Posts: n/a

02-07-04, 03:56 PM   #1  
aaron_eckhoff
Fast Flasher on Left turn 2001 F150 4X4

When I indicate a left turn I get a rapid blinker, the left rear
light flashes fast the left front nothing. I replaced the bulb (tried two known good bulbs) Switched out the socket with the working one, checked the fuses, tried a BFH!!! still no go..
Truck is out of warrenty...Dealer says it can't be the flasher
unit or nothing would work.....PLEASE HELP!!!

 
Sponsored Links
Desi501's Avatar
Member

Join Date: Oct 2003
Posts: 2,207

02-07-04, 04:17 PM   #2  
It's not the flasher. The problem is the front one not working. Your going to have to find out why. It may be a ground problem. Usually the problem is right in the pigtail. There should be a verticle strap inside the socket that contacts the side of the bulb, see if that is intact. You may have to use a testlight to test for powers and ground to find the problem. If the problem turns out to be the pigtail, it's easy to snip off the old one and splice a new one in.

 
PNUT883's Avatar
Visiting Guest

Posts: n/a

02-12-04, 12:28 PM   #3  
PNUT883
you said you tried two good bulbs. one in front and one in back or in the same socket. sounds like a stupid question but just curious

 
aaron_eckhoff's Avatar
Visiting Guest

Posts: n/a

03-01-04, 06:40 AM   #4  
aaron_eckhoff
Originally posted by PNUT883
you said you tried two good bulbs. one in front and one in back or in the same socket. sounds like a stupid question but just curious
no both in front because the rear works.

 
michael van's Avatar
Member

Join Date: Nov 2001
Posts: 2,345
TX

03-01-04, 02:18 PM   #5  
hazard flasher

Try your hazard flashers and see with bulb does not work.

 
aaron_eckhoff's Avatar
Visiting Guest

Posts: n/a

03-01-04, 03:32 PM   #6  
aaron_eckhoff
Re: hazard flasher

ok tried Hazards and all but the front left work which is the one I have been working on.

 
michael van's Avatar
Member

Join Date: Nov 2001
Posts: 2,345
TX

03-01-04, 04:10 PM   #7  
Ok

Ok we know it is not the flasher.My next thing I would check is all connections to that light.Can you swap out the assembly from rigt to left just for testing?You will need a DVOM for furter testing after that.But first I would clean all connections real good with a small file or pick.

 
Search this Thread