94 Mercury Cougar

Reply

  #1  
Old 02-23-04, 01:27 AM
juneski
Visiting Guest
Posts: n/a
94 Mercury Cougar

I have 94 Mercury Cougar, V-6. I started it up and this heavy white smoke came out of the tailpipe, it stayed like this for a while. Then I was driving on the freeway and the temperature gauge went from Cold straight to Hot in like a second. The coolant tank is full but the low coolant light keeps coming on. Is it burning oil? What is the problem?, is it a thermostat or water pump? Please help.
 
Sponsored Links
  #2  
Old 02-23-04, 02:49 AM
Desi501's Avatar
Member
Join Date: Oct 2003
Location: Boynton Beach Florida
Posts: 2,207
Sorry, it's much more serious than that. You've got either a blown head gasket or a cracked head. That white smoke is coolant being burned. Time to tear it down and inspect for damage.
 
  #3  
Old 02-23-04, 04:21 AM
carguyinva's Avatar
Member
Join Date: Nov 2003
Location: Shenandoah Valley
Posts: 1,147
must be a 3.8L...

...STOP driving it! check the oil and see if you have a milkshake looking mess. if so...probably roasted the engine...if not, get it to someone (preferably by towing) and have the heads yanked...like desi said...blown head gasket or cracked head.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes