Transmission troubles

Reply

  #1  
Old 03-06-04, 07:32 AM
Member
Thread Starter
Join Date: Oct 2003
Posts: 26
Transmission troubles

Hello. My daughter has a 1996 Mitsibishi Eclipse with 130,000 miles on it. She was driving the car when all of a sudden it started the tranny started slipping. She drove it a little further after that and now it will hardly move in any gear. We got the car with 60,000 miles on it and we never changed the transmission fluid. It is full now, but to you think it would help to change it now or is it too late?
 
Sponsored Links
  #2  
Old 03-06-04, 08:06 AM
Member
Join Date: Feb 2004
Location: So Cal
Posts: 248
eclipse tranny

From what little you describe it sounds like you're going to need to have the tranny replaced.

Matt
 
  #3  
Old 03-06-04, 08:27 AM
mike from nj
Visiting Guest
Posts: n/a
you said it was full of fluid, but what condition is the fluid?

it would be to your benefit to have a very competant shop look at the trans and specifically the stored fault codes. if a sensor fails, on some transmissions, they default to 3rd or 4th all the time, giving the customer the impression that it's slipping. next question, when you hit the gas is the rpm going all the way up, or is it around 1800-2000rpm when it's not moving. this will tell you the good or bad news. i can say i've seen transmissions replaced, and still have the same problem(broken wire in the harness).

i hope you've changed your timing belt at least once by now.

unless the filter is clogged solid, changing the fluid now is worthless.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes