99 Windstar DTC codes

Reply

  #1  
Old 03-06-04, 02:38 PM
Manic Mechanic
Visiting Guest
Posts: n/a
99 Windstar DTC codes

Hi Guys:

A friend and I are looking at the codes we pulled from his van. They are P0171 and P0174 which indicate a lean condition on both banks. After some research, we have noticed that there are a few possible culprits that may throw these codes.

A few are:

1.- Intake manifold gaskets.
2.- The vacuum line to the fuel pressure regulator can cause vacuum leaks and improper fuel pressure.
3.- The MAF sensor.
4.- The fuel filter.
5.- The PCV system.
6.- Stuck EGR valve.
7.- Leaking diaphragm or EVR.
8.- Exhaust leaks near the O2 sensors.

We were just wondering if any of you guys here have had any luck successfully diagnosing these 3.8 Windstars that threw these codes. In other words, what would be our first avenue of pursuit?

There are 48,000 miles on the van and it has always been regularly serviced.

Thanks
 
Sponsored Links
  #2  
Old 03-06-04, 03:42 PM
Member
Join Date: Feb 2004
Location: So Cal
Posts: 248
what to do

Short of a professional diagnosis, I'd recommend taking care of easy stuff like the fuel filter and PCV first.

Your mileage is low so the likelihood of a failed MAF, EGR or EVR, absent any codes, is unlikely.

You could have some restricted fuel injectors causing the lean condition. The best fix for this is to get a MotorVac-style injection service at your local garage, NOT the induction-type that only gets the intake plenum and not much else. MotorVac service will actually due more for the engine than repalcing the spark plugs at this mileage.

You can check for vacuum leaks by CAREFULLY spraying some carb cleaner around vacuum hoses and intake manifold gaskets and listening for the RPM changes. BE CAREFUL and make sure you have a fire extinguisher available just in case.

Inspect the MAF sensor for debris on the screen and carefully spray some BrakeKleen on it to remove the dirt and let it dry.

When you're done you'll have to have someone clear the codes with a scan tool because it's an OBD-II vehicle.

Good luck and let us know how it goes.

Matt
 
  #3  
Old 05-08-04, 05:15 PM
Manic Mechanic
Visiting Guest
Posts: n/a
Smogtek, thanks for your reply.

I finally got time to look at the van again and it turned out to be a dirty mass air flow sensor. The thing that gave it away was the amount of dirt stuck in the air filter.

We cleaned the MAF with an electronic parts cleaner and let it dry. We also installed a new air cleaner and cleaned the air tube that runs between the filter and the throttle body. We cleared the codes using an OBDII scanner and it runs like new again.

I'm now in the process of changing the fuel filter and PCV valve as they are no doubt original.

Thanks again,
Len
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes