Fuel pump or bad gas??

Reply

  #1  
Old 04-03-04, 04:06 PM
chingao81375's Avatar
construction hand
Thread Starter
Join Date: Dec 2003
Location: West Texas
Posts: 114
Fuel pump or bad gas??

I have a 1994 Buick Lesabre with a 3.8 V6. My problem is that one day i filled up a shell station. Traveled 50 miles and it died on me. I tried to start it but to no avail. I waited 2 or 3 minutes and it started. But as soon as i push the gas it died again. I had to wait 2 minutes again. I started it again so i decided to let idle up to speed. It was fine then. I could push the gas gently andit was fine. Until i slowd down and tried to push gas again andit died. I checked the fuel filter it was clean but i replaced it anyway. Several months have passed and now it runs good except when i rev up the engine as high as it will go, it revs up and down every liike its running outta gas but it doesnt die. before i check the fuel pump.....do you think it could be bad gas?? ( the gas station closed down a week after that day)
 
Sponsored Links
  #2  
Old 04-03-04, 04:28 PM
fordman30
Visiting Guest
Posts: n/a
it could be bad gas or when you rev it up as high it will go the computer maybe shutting it down till it gets a certain rpms to let it start back up.this newer cars has a automatic shut off when the motor gets so fast.hope this helps
 
  #3  
Old 04-03-04, 04:35 PM
Desi501's Avatar
Member
Join Date: Oct 2003
Location: Boynton Beach Florida
Posts: 2,207
Re: Fuel pump or bad gas??

Originally posted by chingao81375
I Several months have passed and now it runs good except when i rev up the engine as high as it will go, it revs up and down every liike its running outta gas but it doesnt die. before i check the fuel pump.....do you think it could be bad gas?? ( the gas station closed down a week after that day)
That's just the rev limiter. It's only active in park or neutral.

I think you can forget the bad gas theory. You already drove 50 miles before you had a problem. It's not likely to be the gas. You could have a fuel "pressure" issue though. It needs to be tested at the time the problem is occurring. You need to test the fuel pressure, spark at the plug and injector pulse at the time it won't start. You could look at the fuel pressure now but the other things will check OK until the problem is a total "no start"
 
  #4  
Old 04-04-04, 07:58 PM
chingao81375's Avatar
construction hand
Thread Starter
Join Date: Dec 2003
Location: West Texas
Posts: 114
rev limiter ............who knew! Well i guess i cant do nothing until it acts up again. Hopefully it dont. But i will try to extract any water that might be lingering in the tank. thanks!!!
 
  #5  
Old 04-04-04, 09:02 PM
pagerboy
Visiting Guest
Posts: n/a
Gasline water remover, if that doesn't work it may be the computer. I had a 1989 Olds Cutlass Ciera with the 3.3V6 and had sort of the same problem, replaced two computers before it got better.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes