pontiac grand prix

Reply

  #1  
Old 05-05-04, 05:42 PM
Member
Thread Starter
Join Date: Jul 2003
Location: Florida
Posts: 17
pontiac grand prix

I own a 97 pontiac gran prix Gt. The AC works sometimes and sometimes it does not. I mean, when I turn to switch on to start it to 1, 2, 3, 4 or 5, it sometimes makes a clicking sound and comes on. Other times is does not do it anything unless I turn to switch to the #5 position. Don't know what could be causing this. any help is appreciated.
 
Sponsored Links
  #2  
Old 05-06-04, 05:08 AM
Desi501's Avatar
Member
Join Date: Oct 2003
Location: Boynton Beach Florida
Posts: 2,207
I don't think the fan speed really has any bearing on whether the compressor comes on. The command to come on is initiated as soon as the blower is turned on at all. You may have a weak clutch or relay but it's going to have to be diagnosed at the time it won't come on. You'll have to get a schematic and follow it for testing. Something I usually try first is, at the time it won't come on I take a long bar and carefully tap the clutch plate with a jabbing motion while it's running to determine if it's just a weak clutch. If that makes it start, the it's a weak clutch. If not you could try tapping on the relay but you really need to systematically follow the schematic.
 
  #3  
Old 05-06-04, 06:53 AM
Member
Thread Starter
Join Date: Jul 2003
Location: Florida
Posts: 17
pontiac Grand prix

The compressor starts each time I turn the AC switch and fan on. NO air comes out of the vents unless it is on #5. I have checked it. The air blows out the vent occasionally when I switch it on 1 thru 4. It always works when I switch it to 5.
 
  #4  
Old 05-06-04, 01:02 PM
Desi501's Avatar
Member
Join Date: Oct 2003
Location: Boynton Beach Florida
Posts: 2,207
AH yes, now that's a different story. It's likely a bad blower resister. It's located in the A/C box between the blower motor and the evaporator. It could be under the dash on the passenger side or it could be under the hood near the firewall. I'm not sure about that car. It is a small black piece, about a couple inchs and it screwed into the air box by one or two screws with a multi wire plug in it.
 
  #5  
Old 05-11-04, 10:51 AM
stoney85
Visiting Guest
Posts: n/a
Similar problem, but perhaps more advanced.

I have a 2000 Grand Prix and positons 1 thru 4 are dead. I replaced the resistor pac and it worked for about two weeks and then died again. I thought I smelt something getting hot and sure enough, board #2 bought it.

Any suggestion on where I should look next?

Thank you,
Dave
 
  #6  
Old 05-11-04, 01:46 PM
Desi501's Avatar
Member
Join Date: Oct 2003
Location: Boynton Beach Florida
Posts: 2,207
Originally Posted by stoney85
I thought I smelt something getting hot and sure enough, board #2 bought it.
Any suggestion on where I should look next?
Thank you,
Dave
Check the current draw on the blower motor, also make sure you getting good air flow into the blower motor...re: plastic bags in the intake etc.
 
  #7  
Old 05-11-04, 02:33 PM
stoney85
Visiting Guest
Posts: n/a
Thank you Desi. I will do so.
 
  #8  
Old 01-24-05, 11:58 AM
Member
Thread Starter
Join Date: Jul 2003
Location: Florida
Posts: 17
low coolant light

My 97 pontiac grand prix gt low coolant light flickers on and off and sometimes stays on. I have checked under the hood fluid levels are ok. Should I even be worried about it since levels are ok?
Don't know what else to do. Help?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes