Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

1995 Villager Hard To Start, Blows 5 Ams Fuse


islandermike's Avatar
Visiting Guest

Posts: n/a

05-25-04, 09:54 AM   #1  
islandermike
1995 Villager Hard To Start, Blows 5 Ams Fuse

My 1995 Mercury Villager with 120k miles is blowing the 5 amps Engine Control fuse and hard to start. I know that the fuse has something to do with it, being hard to start, because this was blown once and the effect was exactly the same. The only difference now is that it keeps blowing the 5 amp Engine Contrl Fuse.

Thanks

 
Sponsored Links
davo's Avatar
Member

Join Date: Apr 2002
Posts: 2,417

05-25-04, 03:06 PM   #2  
You will need a wiring diagram to trace that circuit.You may want to try the local library for one.I do not have one maybe someone else who comes here may have it.If you can't find a short in the wiring the pcm may be bad blowing the fuse.

 
billys68ss's Avatar
Member

Join Date: May 2003
Posts: 1,459
WV

05-25-04, 04:54 PM   #3  
That fuse provides power to the PCM and the DRL (Daytime Running Lamp) module. I would disconnect the module to rule that out. You may have a wire that has rubbed through.
Hope this is helpful to ya,
Billy

 
islandermike's Avatar
Visiting Guest

Posts: n/a

05-25-04, 05:01 PM   #4  
islandermike
You are exactly correct. It was the daytime running light that has pinched wired. Thank you very much for your help.

 
Search this Thread