Broken oil pump??? Need some help again!

Reply

  #1  
Old 06-16-04, 06:46 PM
ridelikehell
Visiting Guest
Posts: n/a
Broken oil pump??? Need some help again!

Yet another problem here...

This started by the fact that I have not been getting any readings from my oil pressure guage...thinking that maybe I might have crushed the line in tightening the compression fittings, I took the line out and found that it's fine...So I fired up the engine without that line in place and I've now realised that the block is not pumping out any oil at all? The engine is a 1989 Ford 302...and I had the hose run to the outlet right beside the oil filter...My question is whether or not there is a way to confirm that the oil pump is actually pumping, or is it just for some strange reason not pumping out that hole???

Any help would be greatly apreciated!

--Dave.
 
Sponsored Links
  #2  
Old 06-16-04, 07:12 PM
billys68ss's Avatar
Member
Join Date: May 2003
Location: USA
Posts: 1,459
Take the line completely off of the engine and bump it over to see if you get a stream. It should only take a short bump over to get oil pressure. Is there oil in the engine? What has been done to the engine recently? Have you rebuilt it or what?
Billy
 
  #3  
Old 06-16-04, 07:17 PM
ridelikehell
Visiting Guest
Posts: n/a
yes the engine is a complete rebuild...efi to carb, and a whole bunch of performance goodies...brand new oil pump was put in too which is why i'm kind of confused...and the line is completely out of the engine right now...no oil coming out at all
 
  #4  
Old 06-16-04, 07:21 PM
billys68ss's Avatar
Member
Join Date: May 2003
Location: USA
Posts: 1,459
OK...... Sounds like you might have a proble with the pickup placement. It needs to be level with the bottom of the pan, but not so low or high that it is either touching the pan or above the oil level.

Just a side question.... Do you have a larger sump pan? Or does it have the original style pickup with a different pan than the original.... Fords are a little wacky because they had different style pans with the sump in different locations and therefore required several designs of pickups.
Hope this helps ya,
Billy
 
  #5  
Old 06-16-04, 07:27 PM
ridelikehell
Visiting Guest
Posts: n/a
yep it's a stock pan, stock pickup and stock style pump...

i guess i'm just gonna have to rip it all apart and check to make sure eh
thanks for the help!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes