Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

92 Lumina failed e check


DAN75321's Avatar
New Member

Join Date: Jan 2004
Posts: 114

06-28-04, 07:23 PM   #1  
92 Lumina failed e check

My father has a 1992 Lumina 3.1 with 177k. It failed e check because of high nitrous oxide (2780 ppb). He changed plugs, wires, and air filter. This brought it down to 1700 ppb. He was told his EGR valve or catalytc converter was bad. Service Engine light comes on from time to time. pulled code 31 (TPS) Could this cause the high nitrous oxide? Any info would be greatly appreciated!

Thanks,
Dan

 
Sponsored Links
davo's Avatar
Member

Join Date: Apr 2002
Posts: 2,417

06-29-04, 04:27 AM   #2  
At that mileage the egr port between the egr and intake almost has to be plugged.I usually remove the egr and the throttle body and clean it with a coat hanger.Then I spray some solvent through it and put back together.FYI NOX is oxides of nitrogen not nitrous oxide.I don't think the tps is the problem.Is the car running hot,coolant fan working?Also wouldn't hurt to decarbon the combustion chambers.If this doesn't solve the problem you may have to replace the convertor.A bad O2 sensor could make the car run lean and cause high NOX.The egr port would be my first check though.Also make sure the egr actually opens.

 
DAN75321's Avatar
New Member

Join Date: Jan 2004
Posts: 114

06-29-04, 06:40 AM   #3  
The EGR port is open. EGR valve opens. Is there an easy way to decarbon the combustion chamber? The car isn't running hot. Changing 02 sensor today.

Thanks,
Dan

 
Search this Thread