92 Lumina failed e check

Reply

  #1  
Old 06-28-04, 07:23 PM
New Member
Thread Starter
Join Date: Jan 2004
Posts: 114
92 Lumina failed e check

My father has a 1992 Lumina 3.1 with 177k. It failed e check because of high nitrous oxide (2780 ppb). He changed plugs, wires, and air filter. This brought it down to 1700 ppb. He was told his EGR valve or catalytc converter was bad. Service Engine light comes on from time to time. pulled code 31 (TPS) Could this cause the high nitrous oxide? Any info would be greatly appreciated!

Thanks,
Dan
 
Sponsored Links
  #2  
Old 06-29-04, 04:27 AM
Member
Join Date: Apr 2002
Location: Pittsburgh,Pa
Posts: 2,417
At that mileage the egr port between the egr and intake almost has to be plugged.I usually remove the egr and the throttle body and clean it with a coat hanger.Then I spray some solvent through it and put back together.FYI NOX is oxides of nitrogen not nitrous oxide.I don't think the tps is the problem.Is the car running hot,coolant fan working?Also wouldn't hurt to decarbon the combustion chambers.If this doesn't solve the problem you may have to replace the convertor.A bad O2 sensor could make the car run lean and cause high NOX.The egr port would be my first check though.Also make sure the egr actually opens.
 
  #3  
Old 06-29-04, 06:40 AM
New Member
Thread Starter
Join Date: Jan 2004
Posts: 114
The EGR port is open. EGR valve opens. Is there an easy way to decarbon the combustion chamber? The car isn't running hot. Changing 02 sensor today.

Thanks,
Dan
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes