Engine just died on me I need help

Closed Thread

  #1  
Old 07-09-04, 02:50 AM
Blindboy
Visiting Guest
Posts: n/a
Question Engine just died on me I need help

I have a Renault Clio 1.4 RT L (93), I have been using the car all day, then on way home every thing just stopped, the unsual bit was it was quiet no spluttering or warning just cut out without warning.

I have told it is probably electrical and it had been raining heavly all day, but it been 2 days now and still it won't start. When you go to start it it sounds like it is just about to turn over, but then nothing. Can anyone offer any advise as to the possible cause?

Cheers Blinboy
 
Sponsored Links
  #2  
Old 07-09-04, 03:50 AM
Desi501's Avatar
Member
Join Date: Oct 2003
Location: Boynton Beach Florida
Posts: 2,207
Originally Posted by Blindboy
I have a Renault Clio 1.4 RT L (93),
Well, there's your problem!

LOL just teasing.
You have to approach this like any other "no start" condition. You have to check for 4 things that you need to run

1) compression
2) good spark at the plug
3) correct fuel pressure
4) injecter pulse
 
  #3  
Old 07-09-04, 05:11 AM
Blindboy
Visiting Guest
Posts: n/a
Thanks

I have gone through these, as you suggested, checks and all seems ok, before i start any more work i.e removing major parts like the alternator and checking that i was wondering if their was any other sources as to why this could happen.
 
Closed Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes