Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

1995 geo metro fan belt squeak


stigedis's Avatar
Member

Join Date: Nov 2003
Posts: 45

07-12-04, 07:31 PM   #1  
1995 geo metro fan belt squeak

i replaced the belt on my geo metro (4 cyl) about one month ago. No it squeaks first thing when it starts. i mean loud. appears that after things warm up a bit it no longer squeaks. tried belt dressing with no help. does the belt need to be tightened or loosened? drives me nutz and my neighbors likely too at 5:30am
thanks for the help...
mike

 
Sponsored Links
kuhurdler's Avatar
Member

Join Date: Jul 2002
Posts: 588

07-13-04, 07:40 AM   #2  
I don't have much experience with this myself, but I do have the same problem and am planning to replace the belt and lube up the rollers on the drive belt. I also will rough up the smoothed pulley surfaces a tad with some sandpaper. If that doesn't work, I will probably replace the tensioner. I found this plan of attack by searching through other various forums like this one.
From my reading: if the belt isn't causing it, the rollers on any of the devices the belt touches are the problem. This is the tensioner, alternator, the water pump, the engine and probably something else I am forgetting. The bearings in any of those could be causing it to squeak. For some reason, after the car warms up, the device causing the squeek moves more smoothly, and the pulley no longer slips.

However, I am waiting until after I fix the AC fan problem I have posted about in another thread here. Too many irons in the fire.


Last edited by kuhurdler; 07-13-04 at 09:11 AM.
 
Johnc280's Avatar
Visiting Guest

Posts: n/a

07-13-04, 08:52 AM   #3  
Johnc280
Sounds like the belt is not quite tight enough. Snug it up a little more and see if that helps it.

Johnny

 
Search this Thread