'92 Buick Regal fan not running properly

Reply

  #1  
Old 07-15-04, 03:34 AM
jmorgison
Visiting Guest
Posts: n/a
'92 Buick Regal fan not running properly

We have a 1992 Buick Regal. The fan on the blower motor is not running all the time and never at high speed. ALso AC is not putting out cool air. Are these two problems connected? What do we need to replace?
 
Sponsored Links
  #2  
Old 07-15-04, 07:03 AM
Forum Topic Moderator
Join Date: Oct 2002
Location: Hamilton County, Ohio
Posts: 4,288
I'm looking at a '88 Regal manual - I don't think the '92 is too diifferent.
In the low blower position the power pulls in a low blower relay which then feeds the power thru a resistor pack to the blower motor. In the medium positions, the power bypasses resistors to increase the speed of the motor, and in high, it pulls in a high blower relay which applies full voltage to the motor. It doesn't look like an easy trouble shoot.
The cooling is modulated by vacuum motors and a vacuum leak could keep you from getting full cooling. I know this isn't much help but gives you some spots to start or decide to head for a pro shop.
 
  #3  
Old 07-15-04, 12:55 PM
Member
Join Date: May 2001
Posts: 516
The fan is not designed to runall the time and never at high speed. It usually comes on when you're in city traffic and at idle.
The a/c problem is not related, you probably have a leak in the system and need to get the leak fixed before recharging.
A couple of guys are real good with a/c and will give more accurate advise later.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes