Fuses or something else

Reply

  #1  
Old 07-27-04, 09:16 PM
Member
Thread Starter
Join Date: Jul 2002
Location: AZ
Posts: 24
Question Fuses or something else

1994 Buick Regal

recently my car overheated, after that I noticed that I have no brake lights or turn signals. The lights work when I turn on the lights, just not when I hit the brake. I went through and checked all my fuses that I know of. When I looked through the manuel its says that there is another fuse panel under the instrument panel. I dont see another one, now I didnt tear the panel apart but I am willing if needed. The 2 panels under the hood seem to be fine along with the one located in the glove box.
Does anyone have anyother idea of what it can be that would cause this to happen? or ANY other suggestions would be very helpful.
Thank you.....
 
Sponsored Links
  #2  
Old 07-28-04, 07:52 AM
Forum Topic Moderator
Join Date: Oct 2002
Location: Hamilton County, Ohio
Posts: 4,286
I would first double check the fuses in the glove box with known good fuses. I think that you may find a 20 amp fuse that controls the brake and turnsignal circuits.
 
  #3  
Old 07-28-04, 03:06 PM
Member
Join Date: Apr 2002
Location: Pittsburgh,Pa
Posts: 2,417
If all the fuses are good try checking the brake/turn signal bulbs and check the turn signal switch.If your owners manual says there is another fuse box there probably is so take the hush panel off and look.It may be a small snap in panel it's behind.Also look in the owners manual for the turn signal and brake lamp fuse location to help guide you.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 12:46 AM.