Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

'91 Merc Topaz


64Saratoga's Avatar
Visiting Guest

Posts: n/a

08-07-04, 10:43 PM   #1  
64Saratoga
'91 Merc Topaz

I have two questions regarding my '91 Topaz, 2.3L Auto. My first question is regarding the transmission.

For the past several months it has been making a lot of noise whenever it is at a stop but still in gear. It seems to run rough and this is sometimes accompanied by a jingling noise. As soon as I start moving again the noise disappears, and it is only there if I'm in gear, not in Park or Neutral. I'm assuming this could only be a transmission problem, but I'm not really sure what to look at beyond that. It seems to shift fairly smoothly, although it's a little rough going into third sometimes if I let off the gas.

My second question is about the valve cover. When I bought the car last year, I had to replace the gasket beacause it was leaking. It was only a couple of months before it started leaking again, so I'm about to redo it again. I've been told that there was actually a problem with the vlave covers themselves on these cars, and that this is a really common problem, has anyone else heard of this? Thanks in advance!

-Nick

 
Sponsored Links
davo's Avatar
Member

Join Date: Apr 2002
Posts: 2,417

08-08-04, 05:14 AM   #2  
The jingling noise may be a loose exhaust heat shield or internal catalytic convertor problem.The oil leak I would make sure the pcv system is working properly.

 
Search this Thread