Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

97 Pontiac Grand Am 2.4L Needs Diagnosis!!!


OSUcowboys's Avatar
Visiting Guest

Posts: n/a

08-11-04, 09:25 AM   #1  
OSUcowboys
97 Pontiac Grand Am 2.4L Needs Diagnosis!!!

97 Pontiac Grand Am 2.4L. Have a few questions on it because I have been tricked by these symptoms before.

3 weeks ago, check engine light came on (car was running ok), GM dealer replaced O2 sensor and pack and the car ran fine. A few days ago the check engine light came back on and now the car is starting to jerk inconsistently during acceleration in 2nd-3rd gear and sometimes from take-off.

I have seen plug wires and spark plugs cause this, but also fuel filter. Any ideas on this one and should it have been discovered at the dealer when the check engine light came on.

 
Sponsored Links
carguyinva's Avatar
Member

Join Date: Nov 2003
Posts: 1,147
VA

08-11-04, 09:33 AM   #2  
it's hard to tell...

...unless you have the code from the first episode. if the codes happen to be the same, i'd say the dealer missed it the first time and owes you something. if the codes are different, and they easily could be, then it's probably coincidental.

the bottom line is that you need to know the code stored in the computers memory associated with the check engine lamp. autozone can give you the code and won't charge anything...post the exact number with letters here and someone will decipher it for you and give you some direction.

 
OSUcowboys's Avatar
Visiting Guest

Posts: n/a

08-11-04, 09:41 AM   #3  
OSUcowboys
The repair receipt

The repair receipt from the previous episode doesn't appear on the itemized listing, but it does say:

CUST STATES CK ENGINE LIGHT ON
CHECK FOR CODES P133.BANK 1 OXYGEN SENSOR INOP
REPLACE O2 SENSOR REPLACE VACUUM HOSE TO MAP SENSOR
CLEAR CODE

So that all seems in order. I will run up to an autozone tonight and see if I can get the code for this episode. I will post.

In the meantime, any ideas of the engine trouble Catalytic? Sparkplugs? wires? Fuel Filter? Am I way off?

Thanks for the response

 
Search this Thread