95 olds 98 supercharger

Reply

  #1  
Old 08-21-04, 07:01 AM
kstanley
Visiting Guest
Posts: n/a
95 olds 98 supercharger

I bought this beautiful olds regency elite at auction, truly owned by one little old lady, one owner, 100,000 miles, never smoked in and in fantastic condition, however, I found out that it has a bad supercharger, any ideas on finding one rebuilt, or anyone in Va. that rebuilds these, the price of a new one is truly amazing. I have had the oil changed and checked for any metal, none exists, so the car is truly worth saving. any help ?
 
Sponsored Links
  #2  
Old 08-21-04, 09:49 AM
Member
Join Date: Apr 2002
Location: Pittsburgh,Pa
Posts: 2,417
Did you check the oil level in the supercharger itself(it doesn't use the engine oil system)?You can remove the allen screw to add needed oil(synthetic oil)gm part#12345982 .Those have been known to be noisy and last quite a while in my experience.
 
  #3  
Old 08-21-04, 10:49 AM
kstanley
Visiting Guest
Posts: n/a
will try

I will try that, car starts and runs great, until hot, then low power and valve noise, , no power on acceleration. I hope it is only an oil problem, I appreciate your response.
 
  #4  
Old 08-22-04, 05:51 AM
Member
Join Date: Apr 2002
Location: Pittsburgh,Pa
Posts: 2,417
Have the engine oil pressure checked the supercharger won't cause valve noise after it's warmed up.It could cause a loss of power but the loss would be there all the time.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes