Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

95 olds 98 supercharger


kstanley's Avatar
Visiting Guest

Posts: n/a

08-21-04, 07:01 AM   #1  
kstanley
95 olds 98 supercharger

I bought this beautiful olds regency elite at auction, truly owned by one little old lady, one owner, 100,000 miles, never smoked in and in fantastic condition, however, I found out that it has a bad supercharger, any ideas on finding one rebuilt, or anyone in Va. that rebuilds these, the price of a new one is truly amazing. I have had the oil changed and checked for any metal, none exists, so the car is truly worth saving. any help ?

 
Sponsored Links
davo's Avatar
Member

Join Date: Apr 2002
Posts: 2,417

08-21-04, 09:49 AM   #2  
Did you check the oil level in the supercharger itself(it doesn't use the engine oil system)?You can remove the allen screw to add needed oil(synthetic oil)gm part#12345982 .Those have been known to be noisy and last quite a while in my experience.

 
kstanley's Avatar
Visiting Guest

Posts: n/a

08-21-04, 10:49 AM   #3  
kstanley
will try

I will try that, car starts and runs great, until hot, then low power and valve noise, , no power on acceleration. I hope it is only an oil problem, I appreciate your response.

 
davo's Avatar
Member

Join Date: Apr 2002
Posts: 2,417

08-22-04, 05:51 AM   #4  
Have the engine oil pressure checked the supercharger won't cause valve noise after it's warmed up.It could cause a loss of power but the loss would be there all the time.

 
Search this Thread