Chevy S10 Extreme-runs roughly

Reply

  #1  
Old 08-29-04, 08:40 AM
JungleJim's Avatar
Member
Thread Starter
Join Date: Oct 2003
Location: Ontario, Canada
Posts: 56
Chevy S10 Extreme-runs roughly

Hey guys. My son has a '99 S10 Extreme. 4.3 Vortec, 5 speed man. 70,000 miles. Runs great..except sometimes revs will drop while idiling and then stall. Recently it acts like it's running out of gas, chugs and sputters. There are no codes coming up. Changed fuel filter, checked plugs-ok, wires- ok. Was told it was probably the crank sensor. Changed it...still acts up. Any ideas before the dealer gets it to analyize.
Thanks
 
Sponsored Links
  #2  
Old 08-30-04, 03:18 PM
Member
Join Date: Apr 2002
Location: Pittsburgh,Pa
Posts: 2,417
Clean the throttle body and the IAC valve and see what that gets you.
 
  #3  
Old 08-30-04, 04:53 PM
Desi501's Avatar
Member
Join Date: Oct 2003
Location: Boynton Beach Florida
Posts: 2,207
Originally Posted by davo
Clean the throttle body and the IAC valve and see what that gets you.
I second that.
 
  #4  
Old 08-30-04, 05:01 PM
JungleJim's Avatar
Member
Thread Starter
Join Date: Oct 2003
Location: Ontario, Canada
Posts: 56
Thanks Davo for the reply, turns out it was the ignition coil, plug for the coil was defective.
Thanks for readin' and takin' the time to answer.
Jim
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes