Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Problems with 1990 acura legend...


JJD2207's Avatar
Visiting Guest

Posts: n/a

08-31-04, 09:41 PM   #1  
JJD2207
Problems with 1990 acura legend...

1.) Fan makes high pitched chirping sound from 0-30 and when I slow down. Sound duration is like 5 seconds every time.

2.) Lifters need replaced cuz car ticks

3.) Motor mounts may need to be replaced because car rumbles a little when car isnt in motion.

What are some estimated prices for fixing these things and what stuff can I just buy the parts to and do it myself if I don't have too much experience under the hood? Any input on this would be greatly appreciated. Thanks ahead of time!

 
Sponsored Links
bejay's Avatar
Member

Join Date: Dec 2001
Posts: 2,538

09-01-04, 02:58 AM   #2  
are you sure that you just dont have a loose heat shield on the exhuast sytsem making noise as I dont see any reason for a fan to only make noise from 0 to 30 and when you slow down.
might try a oil additive such as rislone next time you change the oil to see if it helps the ticking noise if it is a lifter or hydralic tappet it may help.

 
Johnc280's Avatar
Visiting Guest

Posts: n/a

09-01-04, 03:57 PM   #3  
Johnc280
I agree with Bejay about the fan. Its a little odd to only make that noise at certain speeds. That fan is electric anyway correct?

The ticking noise is very common from Acura. I have had good luck with oil additives to take care of that problem. The BG product MOA seems to work well but I dont think you can buy it over the shelf.

I recommend you call around for estimates to have the motor mounts replaced and pay someone else to do it.

Good luck.

 
JJD2207's Avatar
Visiting Guest

Posts: n/a

09-01-04, 10:54 PM   #4  
JJD2207
Thanks

Thanks for all the help! I love this car so i just needed to know =)

 
Search this Thread