Gas problem 98 Ford Escort SE 2.0 L. HELP!

Reply

  #1  
Old 09-29-04, 06:41 PM
redhar3
Visiting Guest
Posts: n/a
Unhappy Gas problem 98 Ford Escort SE 2.0 L. HELP!

I have a 1998 Ford Escort SE 2.0 L engine. The service engine light is on and I have had it read three times. The error codes are for "fuel rail scensor" and "system to rich". I have repalaced both the fuel rails twice now along with the fuel filter, fuel pump, and the erg valve. It only runs bad between 40 and 50 miles per hour or going up a hill. It jumps and jerks like it is not getting gas. I have no idea what else to look at does anyone have any new ideas? Help please can afford a mechanic but need the car to get to work.
 
Sponsored Links
  #2  
Old 09-30-04, 02:53 AM
Member
Join Date: Dec 2001
Posts: 2,538
it could be ignition related problem such as a bad plug wire or carbon tracked plug causing it to jerk.
on the check engine light if you have the codes checked and post the actual code or codes back on this thread we may be able to better determine why it is coming on the code will start with a p and have 4 numerical digits after it.
 
  #3  
Old 10-07-04, 07:07 PM
redhar3
Visiting Guest
Posts: n/a
Originally Posted by bejay
it could be ignition related problem such as a bad plug wire or carbon tracked plug causing it to jerk.
on the check engine light if you have the codes checked and post the actual code or codes back on this thread we may be able to better determine why it is coming on the code will start with a p and have 4 numerical digits after it.
thanks for the assistance...here are the codes that have come up on the car when we got it checked...p0172,p0175 and p190 hopefully this will give you a better idea of what it may be...thanks again..
 
  #4  
Old 10-13-04, 06:09 PM
jeherrin
Visiting Guest
Posts: n/a
Try an oxygen sensor. If your getting errors that your too rich that might be it.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes