1986 Chevy Celebrity won't start.

Reply

  #1  
Old 10-01-04, 08:35 PM
Dynam|X
Visiting Guest
Posts: n/a
1986 Chevy Celebrity won't start.

My friend has a 1986 Celebrity wagon. Recently he was over visiting and when he went to leave his car wouldn't start. Over the last month or so we've been trying to pinpoint the problem. We did simple things such as jump starting, and charging the battery. But it didn't help. Next we changed the fuel pump, which didn't help. Recently we disconnected the fuel line going into the fuel injector to see if fuel was getting through the line, which it was. So the problem must be the fuel injector itself we think. We went to a junk yard and got a new entire fuel injection unit (these are the first gen. fuel injections that look like a carb.), we get it installed and the injector still doesn't spray fuel into the intake. We checked the electrical plug that connects to the top of the injector, and it got power. We are now completely lost on what it could be. Could we have gotten another bad injector unit? Any hep would be appreciated.
 
Sponsored Links
  #2  
Old 10-01-04, 08:45 PM
Member
Join Date: Dec 2001
Posts: 2,538
I would guess the vehilce is cranking over just wont start?
you need to check for spark also check to see if the check engine light is coming on when you turn the key on.
 
  #3  
Old 10-01-04, 08:54 PM
Dynam|X
Visiting Guest
Posts: n/a
Correct, the starter cranks, but the injector does not spray fuel. We do know that fuel is getting up to the fuel injection unit. The engine light has been on for years according to the people my friend bought the car from. This car is absolutely torn up, A/C is missing, power steering is missing, etc. Before this final death of the engine happened, the car would sometimes not crank at all, but then 5 minutes later would fire right up. We know we have spark because when we tried starter fluid, the engine would attempt to fire off of it, but would then stop after the fluid was burnt, because no actual gasoline is getting into the engine, because the injector won't spray it.
 
  #4  
Old 10-01-04, 09:14 PM
Member
Join Date: Dec 2001
Posts: 2,538
well you can try checking codes by jumpering the a and b pins on the diagnostic connector usually under drivers side of dash and turn the key on and count the check engine light flashes it will flash each code 3 times and then the process will start over, it should start with a code 12 then whatever codes may also be stored. if it doesnt flash a code 12 check your ecm fuses and single orange wire at battery positve cable, as it may not be suppling power to ecm.
the injector isnt spraying because it isnt getting any pulse to the injector which comes from the ecm, the ecm pulses ground to the injector.
you didnt state engine size but if its a 2.5 it may have a hall effect sensor in the distributer that could be bad gm only used the hall effect for a couple of years so im not for sure your vehicle would even have one if you remove the distributer cap and rotor and if there is a 3 wire sensor directly under the rotor that is the hall effect sensor, could also be a bad ecm or wiring problem.
 
  #5  
Old 10-02-04, 03:54 AM
Member
Join Date: Aug 2003
Location: Barre,Vermont
Posts: 472
Aside from the check engine light coming on for years, right now with it not starting, when u turn the key to the "on" position, does the check engine light come on? This tells if the ECM is getting battery power or not...It should come on with the key in the on position...
 
  #6  
Old 10-02-04, 02:51 PM
Dynam|X
Visiting Guest
Posts: n/a
When the key is turned to "on" the check engine light does come on. Also, it is the 2.5L, sorry for not stating that. There is a small wire coming off the positive terminal, but its black "this may just be grease" and its ripped. Is that the ECM power supply? We weren't sure if it had been ripped before or if it was just done somehow. The car is so torn up under the hood, its hard to tell what is what.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes