Ford Blues

Reply

  #1  
Old 10-06-04, 08:34 AM
Ownsa93sunbird
Visiting Guest
Posts: n/a
Ford Blues

Hey guys, I fixed the ac in my sunbird it was the switch.. moving on to my new problem. I have 1968 Ford f-100 pickup, It has the 390cu engine and an automatic transmission. I just did a tune up on it, Plugs,wires,rotor and distributor cap. I also checked the timing, Now the problem, when accelorating there is a cut out point where the truck will die if you dont let up of off the gas you can pull it away from stalling but if you dont tap the pedal it will die, It doesnt seem to be as bad when the choke is ON.
I've also replaced the fuel filter, inline and The bowl style.
What should I do next?


P.S. the engine only has 96000 miles on the original engine.

Thanx guys
God bless
Later
Craig
 
Sponsored Links
  #2  
Old 10-06-04, 08:36 AM
Ownsa93sunbird
Visiting Guest
Posts: n/a
Me again, after it dies it wont start up for about 15 mins,
*I think it may be flooding*
 
  #3  
Old 10-07-04, 03:31 AM
Join Date: Jun 2002
Location: Long Island, NY
Posts: 1,531
Did you replace the points and condenser and set the timing?

Also try it by disconnecting the vac advance hose off the dist and see what happens.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes