Check Engine Light

Reply

  #1  
Old 10-10-04, 06:22 PM
Member
Thread Starter
Join Date: Aug 2004
Posts: 12
Check Engine Light

97 Saturn SL2, 4cyl., Sedan, 80,000 Miles.
I purchased this car a few months ago and have just recently noticed that the check engine light does not turn on. I checked with the OBD scanner and it says "Error- No link". I then replaced all of the bulbs under the check engine light and checked for faulty wiring and the assembly line data link connector, and the computer command control system. Everything appears to be ok, yet the light will not turn on. The scanner also is still giving me the error message. Any ideas on what could be causing the problem or how it can be diagnosed? Thank you.
 
Sponsored Links
  #2  
Old 10-11-04, 02:58 PM
Member
Join Date: Apr 2002
Location: Pittsburgh,Pa
Posts: 2,417
Check all the fuses under the hood.On the diagnostic connector pin #4 must read ground,pin#16 must be battery voltage,you should not read battery voltage or ground on pin#2.If all checks good you can try disconnecting the abs module and see what happens.Let us know the outcome.
 
  #3  
Old 10-14-04, 07:48 AM
Member
Thread Starter
Join Date: Aug 2004
Posts: 12
Re: Check engine light -saturn

Originally Posted by davo
Check all the fuses under the hood.On the diagnostic connector pin #4 must read ground,pin#16 must be battery voltage,you should not read battery voltage or ground on pin#2.If all checks good you can try disconnecting the abs module and see what happens.Let us know the outcome.
Davo,
Thank you for giving me your suggestions. I checked all of the fuses and they are working. The pin #4 reads ground, pin #16 was orange and works to serial data (PCM- according to Saturn wiring diagram). Pin #2 is purple, but does not specify to where it is connected. Also, the car does not have ABS. According to the diagram, the engine light and the connectors are not directly connected. Why is it possible that they ar-e both not working at the same time? Thank you for your help. I appreciate it.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes